php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6693 problems with session_destroy() function
Submitted: 2000-09-12 18:38 UTC Modified: 2002-04-19 10:20 UTC
From: giancarlo dot favaretti at inforeti dot it Assigned:
Status: Closed Package: Session related
PHP Version: 4.0.2 OS: Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: giancarlo dot favaretti at inforeti dot it
New email:
PHP Version: OS:

 

 [2000-09-12 18:38 UTC] giancarlo dot favaretti at inforeti dot it
I tried several times to use session_destroy() in Windows NT environment with both IIS4 and Apache but it doesn't work returning the warning message "Session object destruction failed" (but It works perfectly in Linux environment).

Configuration of session environment is:
session.auto_start Off 
session.cache_expire 180 
session.cache_limiter nocache 
session.cookie_domain no value 
session.cookie_lifetime 0 
session.cookie_path / 
session.entropy_file no value 
session.entropy_length 0 
session.gc_maxlifetime 1440 
session.gc_probability 1 
session.name PHPSESSID 
session.referer_check no value 
session.save_handler files 
session.save_path C:\TEMP 
session.serialize_handler php 
session.use_cookies On 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-30 03:00 UTC] sas@php.net
Does it unlink the session file (aka object)?
 [2000-10-03 02:59 UTC] waldschrott@php.net
this is dup without further information, #5231 reopened
 [2001-04-27 19:54 UTC] sniper@php.net
fixed in 4.0.4
 [2002-04-19 04:41 UTC] cbl at cbl dot no
Using PHP 4.1.2. on Windows NT 5.0 build 2195

I still get a "Session object destruction failed" warning when running this script:

<?

session_start();
session_unset();
//Sletter og avslutter session
session_destroy();

?>

Any comments?
 [2002-04-19 10:20 UTC] sniper@php.net
Please try the PHP 4.2.0RC4 from http://www.php.net/~derick/
And if it still fails, check that the version number found
in the phpinfo() output is correct.

 [2002-04-21 09:41 UTC] cbl at cbl dot no
Thanks

How can I check that the version number output from phpinfo() is correct?

I am using an ISP, soit is them who has to test PHP 4.2.0RC4 from, it is no use me testing it.

Christian
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 18:03:43 2023 UTC