php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66864 JS-based language selection prevents language selection
Submitted: 2014-03-09 16:57 UTC Modified: 2014-03-10 01:14 UTC
From: phpmpan at mpan dot pl Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpmpan at mpan dot pl
New email:
PHP Version: OS:

 

 [2014-03-09 16:57 UTC] phpmpan at mpan dot pl
Description:
------------
If users use a direct link to enter one of pseudotranslated versions of documentation, the JS-based language selection is set to "English" and prevents them from switching to english. It is required first to switch to some other language and only then it is possible to set english.

Tested on: Fx-27.0.1 on Arch64, but it doesn't seems to be related to browser or platform.

Note: actually after disabling JS it is not possible to change language at all. But I think a separate bug report should be filled for that after this one is resolved.

Test script:
---------------
1. Enter some pseudotranslated documentation page. Example: <http://php.net/manual/pl/class.datetime.php>
2. Try to switch to english.

Expected result:
----------------
Ability to switch to english without a need to switch to some other language first.

Actual result:
--------------
One needs to switch to other language before it is possible to switch to english.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-10 01:14 UTC] bjori@php.net
-Status: Open +Status: Not a bug
 [2014-03-10 01:14 UTC] bjori@php.net
Thats because that translation is no longer marked as active, so we don't want you to be browsing it (e.g. maybe the docs recommend by-now known to be unsecure way of doing things or otherwise buggy).

There should be no links from php.net to those translations, but there may be some around the web. These pages are only meant for archival and historic reference.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 20:05:53 2022 UTC