php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66817 imagecreatefromstring has undocumented warnings
Submitted: 2014-03-03 21:32 UTC Modified: 2016-08-21 12:29 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: php at terite dot com Assigned: cmb (profile)
Status: Closed Package: GD related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at terite dot com
New email:
PHP Version: OS:

 

 [2014-03-03 21:32 UTC] php at terite dot com
Description:
------------
imagecreatefromstring has an undocumented warning when creating from an invalid image source.

Test script:
---------------
<?php
var_dump(imagecreatefromstring('whee php'));

Expected result:
----------------
bool(false)

Actual result:
--------------
PHP Warning:  imagecreatefromstring(): Data is not in a recognized format in /test.php on line 2
PHP Stack trace:
PHP   1. {main}() /test.php:0
PHP   2. imagecreatefromstring() /test.php:2

Warning: imagecreatefromstring(): Data is not in a recognized format in /test.php on line 2

Call Stack:
    0.0001     224640   1. {main}() /test.php:0
    0.0001     225296   2. imagecreatefromstring() /test.php:2

bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-08-21 12:28 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=339917
Log: Fix #66817: imagecreatefromstring has undocumented warnings
 [2016-08-21 12:29 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-08-21 12:29 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-02-07 06:06 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=674885fd4f9776dc58de541eb5be4e9254331ae8
Log: Fix #66817: imagecreatefromstring has undocumented warnings
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC