php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66775 test fail after make clean
Submitted: 2014-02-26 02:26 UTC Modified: 2020-10-04 04:22 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: xuefer at gmail dot com Assigned: cmb (profile)
Status: No Feedback Package: Testing related
PHP Version: 5.5.9 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: xuefer at gmail dot com
New email:
PHP Version: OS:

 

 [2014-02-26 02:26 UTC] xuefer at gmail dot com
Description:
------------
after "make clean" then "make", libtool no longer install extension to modules/ directory, then "make test" will not be able to load extension from this folder

this is a phpize'd module

Test script:
---------------
$ phpize
$ make
/bin/sh /home/xuefer/src/xcache/trunk-php5.5-debug-zts/libtool --mode=install cp ./xcache.la /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules
cp ./.libs/xcache.so /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules/xcache.so
cp ./.libs/xcache.lai /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules/xcache.la
libtool: install: warning: remember to run `libtool --finish /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules'
$ make clean
$ make
/bin/sh /home/xuefer/src/xcache/trunk-php5.5-debug-zts/libtool --mode=install cp ./xcache.la /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules
cp ./.libs/xcache.so /home/xuefer/src/xcache/trunk-php5.5-debug-zts/xcache.so
cp ./.libs/xcache.lai /home/xuefer/src/xcache/trunk-php5.5-debug-zts/xcache.la
libtool: install: warning: remember to run `libtool --finish /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules'
$ make test
/bin/sh: line 12: /home/xuefer/src/xcache/branches/3.1-php5.5-debug-zts/modules/xcache.la: No such file or directory

Expected result:
----------------
/bin/sh /home/xuefer/src/xcache/trunk-php5.5-debug-zts/libtool --mode=install cp ./xcache.la /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules
cp ./.libs/xcache.so /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules/xcache.so
cp ./.libs/xcache.lai /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules/xcache.la
libtool: install: warning: remember to run `libtool --finish /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules'


Actual result:
--------------
/bin/sh /home/xuefer/src/xcache/trunk-php5.5-debug-zts/libtool --mode=install cp ./xcache.la /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules
cp ./.libs/xcache.so /home/xuefer/src/xcache/trunk-php5.5-debug-zts/xcache.so
cp ./.libs/xcache.lai /home/xuefer/src/xcache/trunk-php5.5-debug-zts/xcache.la
libtool: install: warning: remember to run `libtool --finish /home/xuefer/src/xcache/trunk-php5.5-debug-zts/modules'
/bin/sh: line 12: /home/xuefer/src/xcache/branches/3.1-php5.5-debug-zts/modules/xcache.la: No such file or directory

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-23 16:12 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2020-09-23 16:12 UTC] cmb@php.net
Does this still happen to you with any of the actively supported
PHP versions[1]?  If so, does that happen for other extensions as
well, or is this perhaps an xcache issue?

[1] <https://www.php.net/supported-versions.php>
 [2020-10-04 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 24 19:01:23 2020 UTC