php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6674 Apache crashes as soon as I access my server running PHP 4.0.2 + mod_perl 1.24
Submitted: 2000-09-12 04:23 UTC Modified: 2000-12-05 01:54 UTC
From: ruudc at home dot nl Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.2 OS: Linux (Red Hat 6.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ruudc at home dot nl
New email:
PHP Version: OS:

 

 [2000-09-12 04:23 UTC] ruudc at home dot nl
My Apache 1.3.12 server using mod_perl 1.24 (statically linked) and PHP 4.0.2 (dynamic module (.so)) crashes as soon as I access *any* data on the server. "lynx localhost" reports "network errors", and then quits. Netscape just reports that the document is empty.

If I rebuild Apache and leave out mod_perl, everything is fine. If I leave mod_perl in but don't load the PHP module (i.e., comment out the line in httpd.conf) everything is fine as well (except I don't have PHP).

If I check /usr/local/apache/logs/error_log, it says: "Apache/1.3.12 (Unix) PHP/4.0.2 mod_perl/1.24 configured -- resuming normal operations". As soon as I access the server, a new line is added: "child pid xxx exit signal Segmentation fault (11)"

Here's the gdb backtrack output:

#0  0x4039023a in ?? () from /usr/local/apache/libexec/libphp4.so
#1  0x80976b3 in ap_invoke_handler ()
#2  0x80aacc9 in process_request_internal ()
#3  0x80ab0e8 in ap_internal_redirect ()
#4  0x8074ffd in handle_dir ()
#5  0x80976b3 in ap_invoke_handler ()
#6  0x80aacc9 in process_request_internal ()
#7  0x80aad2c in ap_process_request ()
#8  0x80a25ce in child_main ()
#9  0x80a275c in make_child ()
#10 0x80a28b9 in startup_children ()
#11 0x80a2ee6 in standalone_main ()
#12 0x80a3673 in main ()
#13 0x400d79cb in __libc_start_main (main=0x80a332c <main>, argc=3,
    argv=0xbffffb24, init=0x80627d0 <_init>, fini=0x814f61c <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffb1c)
    at ../sysdeps/generic/libc-start.c:92



PHP build was configured with: ./configure --with-mysql=/usr/local --with-apxs=/usr/local/apache/bin/apxs
No warnings at the end (i.e. no warning about e.g. a corrupted apxs script)

Built with just: make , followed by: make install
The php.ini file was just copied and renamed from php.ini-dist

Apache 1.3.12 was compiled with all default modules, with mod_so and mod_perl added. The only thing I changed in httpd.conf is the server name (set to www)

mod_perl is version 1.24, build without any special options.

I use mysql 3.22.32. No additional options during build, just configure, make, make install.

I'm sorry if this is not a bug but is just an error on my side. However, I have read a bunch of faqs and have recompiled all required components several times using several different docs as a guide, but I still end up having the same problem. If you need any more information, please contact me via e-mail.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-01 09:45 UTC] sniper@php.net
Have you tried compiling mod_perl as DSO too?
And please try also using PHP 4.0.3pl1.

--Jani
 [2000-12-05 01:54 UTC] sniper@php.net
This should be fixed in CVS now. Please try latest snapshot from
http://snaps.php.net/  or wait for PHP4.0.4 to be released.

If problem still exists with snapshot or PHP 4.0.4, reopen this bug report.

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 16:01:25 2019 UTC