php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66715 Documentation missing for the AMQP package
Submitted: 2014-02-14 20:43 UTC Modified: 2014-03-07 16:47 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: mdrudi at gmail dot com Assigned: bjori (profile)
Status: Closed Package: amqp (PECL)
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mdrudi at gmail dot com
New email:
PHP Version: OS:

 

 [2014-02-14 20:43 UTC] mdrudi at gmail dot com
Description:
------------
The documentation of the AMQP package is missing from php.net site. If is even shown at the autocomplete in the search box, but when some link is clicked, as for example AMQPChannel, the following error message is shown:

"Not Found

The manual page you are looking for (http://br2.php.net/manual/en/class.amqpchannel) is not available on this server right now. Please check back later, or if the problem persists, contact the webmasters."

The same error is shown for the entire manual.

Test script:
---------------
Point a browser to the URL http://br2.php.net/manual/en/class.amqpchannel

Expected result:
----------------
Have the documentation available for reading.

Actual result:
--------------
Do documentation is available for reading.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-14 20:55 UTC] bjori@php.net
The others of the extension didn't want them on php.net.
See bug #66661

I suspect the autocomplete may be there because of long expire cache headers.. although have to confirm that.
 [2014-02-14 21:16 UTC] mdrudi at gmail dot com
Ok. Thanks for the heads up. Too bad we'll not have the amqp docs on php.net anymore, but no docs is a lot better than outdated docs. 

Looking at https://github.com/pdezwart/php-amqp/tree/master/stubs should work for me. 

Thanks bjori.
 [2014-02-26 00:31 UTC] philip@php.net
FWIW, this bug is still present. How/where is the search stuff generated?
 [2014-03-07 16:46 UTC] bjori@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: bjori
 [2014-03-07 16:46 UTC] bjori@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

It was caused by the "hardcoded developers fixtures" overwriting the actually generated data on the rsync boxes :P
 [2014-03-07 16:47 UTC] bjori@php.net
Uhm. That was clearly a wrong "quickfix" text :).. There was nothing to fix in the extension itself.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 09 21:01:24 2021 UTC