php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66700 SoapClient issue in PHP 5.4.15
Submitted: 2014-02-12 12:53 UTC Modified: 2014-05-08 16:06 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: saneeshkv at gmail dot com Assigned:
Status: No Feedback Package: *XML functions
PHP Version: 5.4.25 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
12 - 9 = ?
Subscribe to this entry?

 
 [2014-02-12 12:53 UTC] saneeshkv at gmail dot com
Description:
------------
When we create a SoapClient object it shows the following error message in PHP 5.4.15

SOAP-ERROR: Parsing WSDL: Couldn't load from '<server name>/webservices/hello.xml' : failed to load external entity '<server name>/webservices/hello.xml'

Note : It is working properly in PHP 5.4.3!

Test script:
---------------
try{
   $sClient = new SoapClient('http://mysitename.com/webservices/hello.xml');
  
  $params = "Aqila";
  $response = $sClient->doHello($params);
  
  var_dump($response);
  
  
} catch(SoapFault $e){
  var_dump($e);
}

Expected result:
----------------
object(SoapClient)[1]
  public '_soap_version' => int 1
  public 'sdl' => resource(4, Unknown)
  public 'httpsocket' => resource(5, stream)
  public '_use_proxy' => int 0
  public 'httpurl' => resource(6, Unknown)

Actual result:
--------------
string(194) "SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://mysitename.com/webservices/hello.xml' : failed to load external entity "http://mysitename.com/webservices/hello.xml"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-02 12:37 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2014-04-02 12:37 UTC] ab@php.net
Please post the contents of the hello.xml. thanks.
 [2014-05-08 16:06 UTC] ab@php.net
-Status: Feedback +Status: No Feedback
 [2014-05-08 16:06 UTC] ab@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 23 00:01:23 2020 UTC