php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66691 sphinx_get_string in Unknown on line 0
Submitted: 2014-02-11 04:27 UTC Modified: 2014-02-11 09:09 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ayuhamaro at gmail dot com Assigned:
Status: Not a bug Package: sphinx (PECL)
PHP Version: 5.4.25 OS: CentOS 6.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ayuhamaro at gmail dot com
New email:
PHP Version: OS:

 

 [2014-02-11 04:27 UTC] ayuhamaro at gmail dot com
Description:
------------
I used PHP Version 5.4.24 and Sphinx sphinx-2.1.5-1.rhel6.x86_64
on CentOS 6.5

module list below

/etc/php.d/curl.ini, /etc/php.d/dba.ini, /etc/php.d/dom.ini, /etc/php.d/fileinfo.ini, /etc/php.d/gd.ini, /etc/php.d/igbinary.ini, /etc/php.d/json.ini, /etc/php.d/mbstring.ini, /etc/php.d/mcrypt.ini, /etc/php.d/mongo.ini, /etc/php.d/mysqlnd.ini, /etc/php.d/mysqlnd_ms.ini, /etc/php.d/mysqlnd_mysql.ini, /etc/php.d/mysqlnd_mysqli.ini, /etc/php.d/pdo.ini, /etc/php.d/pdo_mysqlnd.ini, /etc/php.d/pdo_sqlite.ini, /etc/php.d/phar.ini, /etc/php.d/posix.ini, /etc/php.d/redis.ini, /etc/php.d/solr.ini, /etc/php.d/sphinx.ini, /etc/php.d/sqlite3.ini, /etc/php.d/sysvmsg.ini, /etc/php.d/sysvsem.ini, /etc/php.d/sysvshm.ini, /etc/php.d/wddx.ini, /etc/php.d/xmlreader.ini, /etc/php.d/xmlwriter.ini, /etc/php.d/xsl.ini, /etc/php.d/zip.ini 


Before, I used an earlier version PHP, and the like may be 5.4.19, Sphinx PEAR working properly. However, after upgrading to PHP 5.4.24, just use MySQL connection, the following message appears:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sphinx.so' - /usr/lib64/php/modules/sphinx.so: undefined symbol: sphinx_get_string in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sphinx.so' - /usr/lib64/php/modules/sphinx.so: undefined symbol: sphinx_get_string in Unknown on line 0

the file sphinx.so is exist

And, phpinfo There is no information Sphinx, I think it was there before

Test script:
---------------
$link = mysql_connect('xx.xx.xx.xx', 'xxx', 'xxx');

Expected result:
----------------
There should be no error messages

Actual result:
--------------
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sphinx.so' - /usr/lib64/php/modules/sphinx.so: undefined symbol: sphinx_get_string in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sphinx.so' - /usr/lib64/php/modules/sphinx.so: undefined symbol: sphinx_get_string in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-11 08:20 UTC] tony2001@php.net
Can you show me the output of `ldd /usr/lib64/php/modules/sphinx.so`?
What's the version of libsphinclient installed in your system?
 [2014-02-11 08:20 UTC] tony2001@php.net
-Status: Open +Status: Feedback
 [2014-02-11 08:33 UTC] ayuhamaro at gmail dot com
Dear Tony

output of `ldd /usr/lib64/php/modules/sphinx.so` is
linux-vdso.so.1 =>  (0x00007fff1dbff000)
libsphinxclient-0.0.1.so => /usr/lib64/libsphinxclient-0.0.1.so (0x00007fcb04628000)
libc.so.6 => /lib64/libc.so.6 (0x00007fcb04294000)
/lib64/ld-linux-x86-64.so.2 (0x0000003948000000)

version of libsphinclient is
libsphinxclient-0.9.9-1.el6.rf.x86_64.rpm
 [2014-02-11 08:45 UTC] tony2001@php.net
It seems that the extension has been built with newer version of libsphinxclient, which does have sphinx_get_string() function.
If you built it yourself, please make sure you have headers from the matching version of libsphinxclient and rebuild the extension.
If you're using some packages, then you'll have to report that to the people who built these packages - obviously a higher version of libsphinxclient should be required.
Upgrading libsphinxclient should also help.
 [2014-02-11 09:00 UTC] ayuhamaro at gmail dot com
Thank you very much 

I upgraded to libsphinxclient-2.0.8-1.el6.x86_64.rpm, has been working properly

:D
 [2014-02-11 09:01 UTC] ayuhamaro at gmail dot com
-Status: Feedback +Status: Closed
 [2014-02-11 09:01 UTC] ayuhamaro at gmail dot com
Resolved
 [2014-02-11 09:09 UTC] tony2001@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 22:01:24 2020 UTC