php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66626 memcached::delete Time parameter not working
Submitted: 2014-02-02 04:29 UTC Modified: 2021-06-09 11:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: lordi at msdi dot ca Assigned: cmb (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 5.4.24 OS: FreeBSD 9.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lordi at msdi dot ca
New email:
PHP Version: OS:

 

 [2014-02-02 04:29 UTC] lordi at msdi dot ca
Description:
------------
The parameter int $time doesnt work if different from 0

Memcached reports error 38 with message: INVALID ARGUMENTS

Here are the versions I am running
libmemcached-1.0.7_1                =   up-to-date with port
memcached-1.4.17                    =   up-to-date with port
pecl-memcached-2.1.0                =   up-to-date with port

Test script:
---------------
$m = new Memcached();
$m->addServer('127.0.0.1', 11211);

$m->set('test','Hello');
echo $m->get('test'); //Should output "Hello", this is working fine
$m->delete('test',1);
echo $m->get('test'); //Shouldn't output anything since the value should have been deleted. This is not working (ie, outputs, Hello)
$m->delete('test',0);
echo $m->get('test'); //Shouldn't output anything since the value should have been deleted. This is working since the parameter is not=0

Expected result:
----------------
Hello

Actual result:
--------------
HelloHello

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-09 11:54 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-06-09 11:54 UTC] cmb@php.net
The memcached bug tracker is now on Github[1].  If this is still
an issue with the current memcached version, please report there.

[1] <https://github.com/php-memcached-dev/php-memcached/issues>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 17:01:31 2024 UTC