php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6661 XML declaration tries to be parsed
Submitted: 2000-09-11 21:44 UTC Modified: 2000-09-11 22:09 UTC
From: chris at billingsgazette dot com Assigned:
Status: Closed Package: XML related
PHP Version: 4.0.2 OS: SuSE Linux 6.4 (2.2.14)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chris at billingsgazette dot com
New email:
PHP Version: OS:

 

 [2000-09-11 21:44 UTC] chris at billingsgazette dot com
Theoretically, the following code *should* work without any errors.  However, PHP tries to parse the XML declaration statement, and returns the following error "Parse error: parse error in /www/bugtest.php on line 5"
-------------
<?php
$title = "Test for PHP bug displaying XHTML";
?>

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">
<html>
 <head>
  <title><?php echo $title ?></title>
 </head>
 <body>
  <p>This is an XHTML document.  Oh yeah, hello world!</p>
 </body>
</html>
-------------

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-11 22:09 UTC] chris at billingsgazette dot com
was informed that this is not a bug.  : )
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 22 18:03:35 2022 UTC