php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #66527 For array of objects variables
Submitted: 2014-01-21 07:38 UTC Modified: 2014-01-21 07:55 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: aroramanish63 at gmail dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.4.24 OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aroramanish63 at gmail dot com
New email:
PHP Version: OS:

Further comment on this bug is unnecessary.

 

 [2014-01-21 07:38 UTC] aroramanish63 at gmail dot com
Description:
------------
I have some code which is used to get objects properties in json using json_decode. In the objects properties some properties are private or protected. when i print array using var_dump then its not showing the protected data objects properties. So my question is that, How to create objects array which is use to include the protected and private properties.

Thanks in advance.

Test script:
---------------
I have some code which is used to get objects properties in json using json_decode. In the objects properties some properties are private or protected. when i print array using var_dump then its not showing the protected data objects properties. So my question is that, How to create objects array which is use to include the protected and private properties.

Thanks in advance.

Expected result:
----------------
I have some code which is used to get objects properties in json using json_decode. In the objects properties some properties are private or protected. when i print array using var_dump then its not showing the protected data objects properties. So my question is that, How to create objects array which is use to include the protected and private properties.

Thanks in advance.

Actual result:
--------------
I have some code which is used to get objects properties in json using json_decode. In the objects properties some properties are private or protected. when i print array using var_dump then its not showing the protected data objects properties. So my question is that, How to create objects array which is use to include the protected and private properties.

Thanks in advance.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-21 07:55 UTC] rasmus@php.net
-Status: Open +Status: Not a bug -Block user comment: No +Block user comment: Yes
 [2014-01-21 07:55 UTC] rasmus@php.net
This is not a support forum, this is a bug tracking system.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 18:01:29 2020 UTC