php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66492 imageflip example images don't match example code
Submitted: 2014-01-15 22:28 UTC Modified: 2016-06-14 15:45 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sleeping at myperch dot org Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 5.5.8 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sleeping at myperch dot org
New email:
PHP Version: OS:

 

 [2014-01-15 22:28 UTC] sleeping at myperch dot org
Description:
------------
---
From manual page: http://www.php.net/function.imageflip
---

The first example is for vertical flipping but the example image is horizontally flipped. The second example is for horizontal flipping but the image is vertically flipped.

Either switch the images around, or the code blocks.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-14 15:45 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-06-14 15:45 UTC] cmb@php.net
The documentation is correct (at least as it's now). The constants
might be misleading, though. IMG_FLIP_HORIZONTAL means flip in
horizontal direction, but not mirror on a horizontal axis.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 21:01:23 2020 UTC