php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66464 failing tests
Submitted: 2014-01-11 13:40 UTC Modified: 2015-06-09 22:15 UTC
From: spam2 at rhsoft dot net Assigned: cmb (profile)
Status: Closed Package: Testing related
PHP Version: 5.5.8 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
14 + 21 = ?
Subscribe to this entry?

 
 [2014-01-11 13:40 UTC] spam2 at rhsoft dot net
Description:
------------
besides that 5.5.7 and 5.5.8 broke opcache horrible (https://bugs.php.net/bug.php?id=66460) there are way too much failing tests over a longer time and it feels the amount is growing

TEST FAILURE: ../sapi/cli/tests/017.diff --
008- 
018- 
029- 
037+ PHP Parse error:  syntax error, unexpected ')' in php shell code on line 1

FAILED TEST SUMMARY
---------------------------------------------------------------------
Zend Multibyte and UTF-8 BOM [Zend/tests/multibyte/multibyte_encoding_002.phpt]
Zend Multibyte and UTF-16 BOM [Zend/tests/multibyte/multibyte_encoding_003.phpt]
timezone_location_get: Test that timezone_location_get returns a correct array of information [ext/date/tests/timezone_location_get.phpt]
DBA DB4 File Creation open("c") with existing file [ext/dba/tests/dba_db4_003.phpt] (info: DB4 handler used)
DBA DB4 File Creation popen("c") with existing invalid file [ext/dba/tests/dba_db4_007.phpt] (info: DB4 handler used)
DBA DB4 magic_quotes_runtime Test [ext/dba/tests/dba_db4_010.phpt] (info: DB4 handler used)
DBA INIFILE handler test [ext/dba/tests/dba_inifile.phpt]
IntlDateFormatter, calendars and time zone [ext/intl/tests/dateformat_calendars.phpt]
IntlDateFormatter: several forms of the calendar arg [ext/intl/tests/dateformat_create_cal_arg.phpt]
datefmt_format_code() [ext/intl/tests/dateformat_format.phpt]
IntlDateFormatter::formatObject(): IntlCalendar tests [ext/intl/tests/dateformat_formatObject_calendar.phpt]
IntlDateFormatter::formatObject(): DateTime tests [ext/intl/tests/dateformat_formatObject_datetime.phpt]
datefmt_format_code() and datefmt_parse_code() [ext/intl/tests/dateformat_format_parse.phpt]
IntlDateFormatter: setCalendar()/getCalendar()/getCalendarObject() [ext/intl/tests/dateformat_get_set_calendar.phpt]
IntlDateFormatter: get/setTimeZone() [ext/intl/tests/dateformat_get_set_timezone.phpt]
datefmt_set_timezone_id_code() icu >= 4.8 [ext/intl/tests/dateformat_set_timezone_id2.phpt]
IntlDateFormatter: several forms of the timezone arg [ext/intl/tests/dateformat_timezone_arg_variations.phpt]
numfmt_get_locale() [ext/intl/tests/formatter_get_locale.phpt]
locale_filter_matches.phpt() icu >= 4.8 && icu < 51.2 [ext/intl/tests/locale_filter_matches2.phpt]
locale_get_display_name() icu >= 4.8 && icu < 51.2 [ext/intl/tests/locale_get_display_name2.phpt]
locale_get_display_region() icu >= 4.8 && icu < 51.2 [ext/intl/tests/locale_get_display_region2.phpt]
locale_lookup.phpt() [ext/intl/tests/locale_lookup.phpt]
MessageFormat accepts IntlCalendar args [ext/intl/tests/msgfmt_format_intlcalendar.phpt]
ResourceBundle constructor bundle accepts NULL for first two arguments [ext/intl/tests/resourcebundle_null_mandatory_args.phpt]
IntlTimeZone::getDisplayName(): type parameter (ICU >= 49 && ICU < 51.2) [ext/intl/tests/timezone_getDisplayName_variant2-49+.phpt]
Bug #36745 (LOAD DATA LOCAL INFILE doesn't return correct error message) [ext/mysqli/tests/bug36745.phpt]
Bug #42548 PROCEDURE xxx can't return a result set in the given context (works in 5.2.3!!) [ext/mysqli/tests/bug42548.phpt]
Bug #44879 (failed to prepare statement) [ext/mysqli/tests/bug44897.phpt]
Bug #51647 (Certificate file without private key (pk in another file) doesn't work) [ext/mysqli/tests/bug51647.phpt]
Bug #53503 (mysqli::query returns false after successful LOAD DATA query) [ext/mysqli/tests/bug53503.phpt]
Bug #55283 (SSL options set by mysqli_ssl_set ignored for MySQLi persistent connections) [ext/mysqli/tests/bug55283.phpt]
mysqli_change_user() [ext/mysqli/tests/mysqli_change_user.phpt]
mysqli->change_user() [ext/mysqli/tests/mysqli_change_user_oo.phpt]
Interface of the class mysqli_driver [ext/mysqli/tests/mysqli_class_mysqli_driver_interface.phpt]
mysqli_connect() [ext/mysqli/tests/mysqli_connect.phpt]
new mysqli() [ext/mysqli/tests/mysqli_connect_oo.phpt]
mysqli_driver class [ext/mysqli/tests/mysqli_driver.phpt]
mysqli_fetch_field() - flags/field->flags [ext/mysqli/tests/mysqli_fetch_field_flags.phpt]
Forking a child and using the same connection. [ext/mysqli/tests/mysqli_fork.phpt]
mysqli_get_client_stats() [ext/mysqli/tests/mysqli_get_client_stats.phpt]
mysqli_pconnect() [ext/mysqli/tests/mysqli_pconnect.phpt]
mysqli_query() [ext/mysqli/tests/mysqli_query.phpt]
mysqli_query() - Stored Procedures [ext/mysqli/tests/mysqli_query_stored_proc.phpt]
mysqli_query() - unicode (cyrillic) [ext/mysqli/tests/mysqli_query_unicode.phpt]
mysqli_real_query() [ext/mysqli/tests/mysqli_real_query.phpt]
mysqli_report() [ext/mysqli/tests/mysqli_report.phpt]
mysqli_report() [ext/mysqli/tests/mysqli_report_wo_ps.phpt]
mysqli_stmt_execute() - Stored Procedures [ext/mysqli/tests/mysqli_stmt_execute_stored_proc.phpt]
readline_callback_handler_install(): Basic test [ext/readline/tests/readline_callback_handler_install_001.phpt]
readline_callback_handler_remove(): Basic test [ext/readline/tests/readline_callback_handler_remove_001.phpt]
readline_clear_history(): Basic test [ext/readline/tests/readline_clear_history_001.phpt]
readline_info(): Basic test [ext/readline/tests/readline_info_001.phpt]
readline_write_history(): Basic test [ext/readline/tests/readline_write_history_001.phpt]
use_trans_sid should not affect SID [ext/session/tests/015.phpt]
rewriter correctly handles attribute names which contain dashes [ext/session/tests/018.phpt]
rewriter uses arg_separator.output for modifying URLs [ext/session/tests/020.phpt]
Bug #26862 (ob_flush() before output_reset_rewrite_vars() results in data loss) [ext/session/tests/bug26862.phpt]
Bug #31454 (Incorrect adding PHPSESSID to links, which contains \r\n) [ext/session/tests/bug36459.phpt]
Bug #41600 (url rewriter tags doesn't work with namespaced tags) [ext/session/tests/bug41600.phpt]
Bug #50308 (session id not appended properly for empty anchor tags) [ext/session/tests/bug50308.phpt]
Bug #44394 (Last two bytes missing from output) [ext/standard/tests/general_functions/bug44394.phpt]
Bug #44394 (Last two bytes missing from output) with session.use_trans_id [ext/standard/tests/general_functions/bug44394_2.phpt]
Bug #38802 (ignore_errors and max_redirects) [ext/standard/tests/http/bug38802.phpt]
Bug #48929 (duplicate \r\n sent after last header line) [ext/standard/tests/http/bug48929.phpt]
Bug #53198 (From: header cannot be changed with ini_set) [ext/standard/tests/http/bug53198.phpt]
Bug #61548 (content-type must appear at the end of headers) [ext/standard/tests/http/bug61548.phpt]
http:// and ignore_errors [ext/standard/tests/http/ignore_errors.phpt]
Bug #26817 (http_build_query() did not handle private & protected object properties) [ext/standard/tests/strings/bug26817.phpt]
http_build_query() function [ext/standard/tests/strings/http_build_query.phpt]
Test http_build_query() function: usage variations - first arguments as object [ext/standard/tests/strings/http_build_query_variation1.phpt]
Test http_build_query() function: usage variations - first arguments as multidimensional array and second argument present/not present [ext/standard/tests/strings/http_build_query_variation2.phpt]
Test http_build_query() function: usage variations - testing four parameter added in PHP 5.4.0 [ext/standard/tests/strings/http_build_query_variation3.phpt]
Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
Test function show_source() by calling it with its expected arguments, more test for highlight_file() [ext/standard/tests/strings/show_source_basic.phpt]
Test function show_source() by calling it with its expected arguments and php output, more test for highlight_file() [ext/standard/tests/strings/show_source_variation1.phpt]
Test function show_source() by calling it with its expected arguments and output to variable, more test for highlight_file() [ext/standard/tests/strings/show_source_variation2.phpt]
_______________________________________________

with MariaDB 5.5.34 there are also query errors inside the test-suite

001+ Warning: mysqli_multi_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'BAR; FOO' at line 1 in /home/builduser/rpmbuild/BUILD/php-5.5.8/ext/mysqli/tests/mysqli_report.php on line 35
001- Warning: mysqli_multi_query(): (%d/%d): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'BAR; FOO' at line 1 in %s on line %d
003+ Warning: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'FOO' at line 1 in /home/builduser/rpmbuild/BUILD/php-5.5.8/ext/mysqli/tests/mysqli_report.php on line 36
003- Warning: mysqli_query(): (%d/%d): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FOO' at line 1 in %s on line %d
009+ Warning: mysqli_prepare(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'FOO' at line 1 in /home/builduser/rpmbuild/BUILD/php-5.5.8/ext/mysqli/tests/mysqli_report.php on line 42
009- Warning: mysqli_prepare(): (%d/%d): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FOO' at line 1 in %s on line %d
011+ Warning: mysqli_real_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'FOO' at line 1 in /home/builduser/rpmbuild/BUILD/php-5.5.8/ext/mysqli/tests/mysqli_report.php on line 43
011- Warning: mysqli_real_query(): (%d/%d): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FOO' at line 1 in %s on line %d
015+ Warning: mysqli_stmt_prepare(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'FOO' at line 1 in /home/builduser/rpmbuild/BUILD/php-5.5.8/ext/mysqli/tests/mysqli_report.php on line 68
015- Warning: mysqli_stmt_prepare(): (%d/%d): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FOO' at line 1 in %s on line %d-- ../ext/mysqli/tests/mysqli_report.diff result ends.


Expected result:
----------------
not so much failing tests, no syntax errors in tests

Actual result:
--------------
faling tests, syntax errors in tests

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-09 22:15 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2015-06-09 22:15 UTC] cmb@php.net
Firstly, the proper way to report failing (and not failing) tests
is to send an email to the QA team after running `make test` by
confirming the respective question. This allows for an useful
overview, see below.

It is okay to bring attention to a single test (or a few closely
related tests) by filing a respective bug report, but it is not
helpful to list all failing tests, and it is even less useful to
complain about many failing tests in a bug report (use the
appropriate mailing list for this).

So let's concentrate on the mentioned sapi/cli/017.phpt. This test
also fails on my Ubuntu 14.04 running PHP 5.5.8. On a closer look
this is due to whitespace errors. The statistics[1] confirm that:
for me it's the same as for most (4 missing empty lines).

However, on PHP 5.5.25 this test passes, what is again confirmed
by the stats[2].

I'm therefore closing this ticket.

[1] 
<https://qa.php.net/reports/viewreports.php?version=5.5.8&test=%2Fsapi%2Fcli%2Ftests%2F017.phpt>
[2] <https://qa.php.net/reports/viewreports.php?version=5.5.25&test=%2Fsapi%2Fcli%2Ftests%2F017.phpt>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 02:01:23 2020 UTC