php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66454 resampleImage is not working
Submitted: 2014-01-10 04:08 UTC Modified: 2014-01-24 13:11 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: szgeri at gmail dot com Assigned:
Status: Not a bug Package: gmagick (PECL)
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: szgeri at gmail dot com
New email:
PHP Version: OS:

 

 [2014-01-10 04:08 UTC] szgeri at gmail dot com
Description:
------------
When calling 

$image->resampleImage(100, 100, null, 1);

it does not do anything to the image. resizeImage() is working.

Test script:
---------------
$originalFileName = "in.jpg";
$currentVersionFileName = "out.jpg";


$image = new Gmagick();

$image->readImage($originalFileName);

$image->resampleImage(100, 100, null, 1);

$image->writeImage($currentVersionFileName);

$image->destroy();

Expected result:
----------------
The image gets resampled to 100x100.

Actual result:
--------------
The image remains unaffected.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-20 19:32 UTC] compuchad+bugs dot php dot net at gmail dot com
If percentages are used instead of resolution then the image does, in fact, become resampled. For example... $image->resampleImage(100, 50, gmagick::FILTER_UNDEFINED, 1) produces an image that is 100% as wide as it was and 50% as tall.
 [2014-01-24 13:02 UTC] vito@php.net
-Status: Open +Status: Not a bug
 [2014-01-24 13:02 UTC] vito@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2014-01-24 13:11 UTC] vito@php.net
Please log this at:

https://sourceforge.net/p/graphicsmagick/_list/tickets

Gmagick calls:

MagickResampleImage(intern->magick_wand, xRes, yRes, filter, blur);

correctly.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 12 01:01:24 2021 UTC