php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66415 Search Box is Missing!
Submitted: 2014-01-05 05:37 UTC Modified: 2015-01-11 08:56 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:3 (75.0%)
From: TygerGilbert at USAWebAdv dot com Assigned: Unassigned (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: WinXP w/ IE8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: TygerGilbert at USAWebAdv dot com
New email:
PHP Version: OS:

 

 [2014-01-05 05:37 UTC] TygerGilbert at USAWebAdv dot com
Description:
------------
In addition to all the other things on this documentation website that are formatted badly or don't work in IE-8, the SEARCH box is missing now. When I'm in the Functions pages, there is no Search box at the top (or anywhere else) for me to enter a word or phrase to search the documentation for. It just isn't there! Compatibility mode or not. And the "Stop running this script?" error dialog box still pops up on every page. The Search box appears normally with Chrome and Firefox, but not IE-8. I know you guys hate Microsoft and its products, but I don't wish to learn another browser just to access PHP.net. The latest redesign of the website just keeps making things more difficult to find whatever it is that I need. (Further, this form keeps telling me I must reupload the patch file when the patch name fields are empty -- because there isn't a patch file to upload. Then I have to do the math again and resubmit with the fields empty.)

Expected result:
----------------
I expect to see a Search form box at the top of the page.

Actual result:
--------------
There is no Search form box at the top of the page. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-05 14:32 UTC] will4096 at vfemail dot net
I can confirm this problem with IE8. Error reported is:

Operation aborted
  typeahead.min.js, line 7 character 989

A similar problem occurs in FF11.  The search box appears but FF stalls with:

Unresponsive Script
  Script: h..p://uk3.php.net/cached.php?t=1385000409&f=/js/ext/typeahead.min.js:7

Stopping the script (the only way out) means autocomplete in the search box doesn't work.	
	

I appreciate this isn't your script but this is making php.net documentation effectively unworkable since this delay occurs on *every* page load on the site.

(Note this has been happening ever since the redesign last Nov.)

(and please don't say use a newer browser - I have to use old browsers for backwards compatibility testing)
 [2014-01-06 06:48 UTC] bjori@php.net
-Package: Documentation problem +Package: Website problem -Assigned To: +Assigned To: aharvey
 [2014-01-06 06:48 UTC] bjori@php.net
Knowing its typeahead.min.js actual is really helpful.
Thanks for the report!
 [2014-03-25 14:18 UTC] lonkelley at hotmail dot com
I am using Windows 7 64 bit, but The Company requires us to use IE 8. I get a very similar error, but it flags a different package:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; UHG_Win7_Build 11-15-2010)
Timestamp: Tue, 25 Mar 2014 14:07:04 UTC


Message: Not enough storage is available to complete this operation.

Line: 248
Char: 25
Code: 0
URI: http://us2.php.net/cached.php?t=1388140826&f=/js/search.js
 [2014-03-25 16:09 UTC] aharvey@php.net
-Status: Assigned +Status: Duplicate
 [2014-03-25 16:09 UTC] aharvey@php.net
Duplicate of bug #66207.
 [2014-03-25 17:16 UTC] will4096 at vfemail dot net
Not a duplicate! Only the comment made by lonkelley is a duplicate (of #66207) and that has nothing to do with this bug.
 [2014-03-25 17:18 UTC] aharvey@php.net
-Status: Duplicate +Status: Re-Opened
 [2014-03-25 17:18 UTC] aharvey@php.net
Right you are, sorry. Although, to be blunt, the answer is mostly "use a newer browser", even though I know you don't want to hear that.
 [2014-03-25 18:27 UTC] will4096 at vfemail dot net
True. :-) Unfortunately those of us 'stuck' on XP have no newer alternative to IE8
 [2014-03-25 19:56 UTC] levim@php.net
The core php.net developers I know don't have access to a machine to test IE 8 support and neither do I; we can't support it.

As an aside I suggest that you seek new employment if you are restricted by your company to use any specific browser, but especially if that browser is IE 8.
 [2014-03-25 20:00 UTC] levim@php.net
Since the release of our website typeahead.js has undergone a major rewrite. Once I get it upgraded (not promising any timeline) I'll post here and we can see if IE 8 has these issues.
 [2015-01-03 11:14 UTC] jacob@php.net
-Assigned To: aharvey +Assigned To: jacob
 [2015-01-11 08:56 UTC] jacob@php.net
-Status: Re-Opened +Status: Closed -Assigned To: jacob +Assigned To: Unassigned
 [2015-01-11 08:56 UTC] jacob@php.net
PHP.net's support for browsers only covers current stable and prior release and this issue is related to an unsupported OS/Browser combination I am closing this one off.

Should someone want to support this, feel free to reopen and assign.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 09:01:26 2024 UTC