php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66360 Opcache CLI option enabled breaks PHP -v
Submitted: 2013-12-27 11:50 UTC Modified: 2014-12-30 10:42 UTC
From: ceceldada at gmail dot com Assigned: dmitry (profile)
Status: No Feedback Package: opcache
PHP Version: 5.5.7 OS: Centos 6.4 2.6.18-028stab107.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ceceldada at gmail dot com
New email:
PHP Version: OS:

 

 [2013-12-27 11:50 UTC] ceceldada at gmail dot com
Description:
------------
After I updated the PHP version from 5.5.6 to 5.5.7 and enabled the Opcache extension with CLI option enabled too, the PHP option arguments like -v, -i and -m doesn't work.

Expected result:
----------------
[root@server jq]# php -v
PHP 5.5.7 (cli) (built: Dec 13 2013 11:51:35) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies

Actual result:
--------------
[root@server jq]# php -v
[root@server jq]#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-29 09:54 UTC] krakjoe@php.net
-Assigned To: +Assigned To: dmitry
 [2013-12-29 09:54 UTC] krakjoe@php.net
I cannot reproduce this using default options, so assigning to dmitry to take a look ...
 [2013-12-29 10:12 UTC] dmitry@php.net
-Status: Assigned +Status: Feedback
 [2013-12-29 10:12 UTC] dmitry@php.net
It works fine to me.
It must be a build or installation problem.
 [2014-12-30 10:42 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 03:01:24 2020 UTC