php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66308 echo error
Submitted: 2013-12-17 16:21 UTC Modified: 2013-12-17 16:45 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: cbsgroup at yandex dot ru Assigned:
Status: Not a bug Package: hash related
PHP Version: 5.5.7 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cbsgroup at yandex dot ru
New email:
PHP Version: OS:

 

 [2013-12-17 16:21 UTC] cbsgroup at yandex dot ru
Description:
------------
echo does not show all the decrypted data

Test script:
---------------
echo base64_decode('dC42SWp9VHADdH1CBXVDYGJBeyUrfAYfRBg8RgEaAwwjQndNbGAScAN0fUVUdUNgYkFzJSt8Bh8XZBUDBR0FZAoHc01teW5ZRnB6FGlcBmRlQnxYfA==');

Expected result:
----------------
t.6Ij}Tpt}BuC`bA{%+|D<F#BwMl`pt}ETuC`bAs%+|dd
sMmynYFpzi\deB|X|

Actual result:
--------------
t.6Ij}Tpt}BuC`bA{%+|D

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-17 16:45 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2013-12-17 16:45 UTC] rasmus@php.net
That's not a PHP issue. That's because you are not looking at the raw output. If you are using a web browser, do a "view source" to see it. If you are using the command line, try sending the output to something like od -c or redirect it to a file.

eg.
% php -r "echo base64_decode('dC42SWp9VHADdH1CBRgEaAwwjQndNbGAScAN0fUVUdUNgYkFzJSt8Bh8XZBUDBR0FZAoHc01teW5ZRnB6FGlcBmRlQnxYfA==');" | od -c

0000000   t   .   6   I   j   }   T   p 003   t   }   B 005   u   C   `
0000020   b   A   {   %   +   | 006 037   D 030   <   F 001 032 003  \f
0000040   #   B   w   M   l   ` 022   p 003   t   }   E   T   u   C   `
0000060   b   A   s   %   +   | 006 037 027   d 025 003 005 035 005   d
0000100  \n  \a   s   M   m   y   n   Y   F   p   z 024   i   \ 006   d
0000120   e   B   |   X   |
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 00:03:36 2021 UTC