php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66301 Cannot load php5apache2_4.dll into server: Access is denied
Submitted: 2013-12-16 15:11 UTC Modified: 2013-12-21 13:44 UTC
From: michael at squiloople dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.5.7 OS: Windows Vista SP 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael at squiloople dot com
New email:
PHP Version: OS:

 

 [2013-12-16 15:11 UTC] michael at squiloople dot com
Description:
------------
Apache 2.4.7 (https://www.apachelounge.com/download/VC11/binaries/httpd-2.4.7-win32-VC11.zip) cannot load php5apache2_4.dll into server. The specific error is:

"Syntax error on line 176 of C:/Apache/conf/httpd.conf: Cannot load C:/PHP/php5apache2_4.dll into server: Access is denied. ."

This issue also occurs in PHP 5.5.6, 5.5.5, and 5.5.4. It does not occur in 5.5.3.

In all cases the Win32 VC11 x86 Thread Safe builds were used.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-17 18:19 UTC] michael at squiloople dot com
Apache 2.4.7 (https://www.apachelounge.com/download/VC11/binaries/httpd-2.4.7-win32-VC11.zip) cannot load php5apache2_4.dll into server. The specific error is:

"Syntax error on line 176 of C:/Apache/conf/httpd.conf: Cannot load C:/PHP/php5apache2_4.dll into server: Access is denied. ."

This issue also occurs in PHP 5.5.6, 5.5.5, and 5.5.4. It does not occur in 5.5.3.

In all cases the Win32 VC11 x86 Thread Safe builds were used.

Using the Dependency Walker the issue seems to be with php5ts.dll; access is denied to php5apache2_4.dll when trying to open it. When trying to open php5ts.dll with the Dependency Walker, even when run as an Administrator, I'm given the Windows alert "You don't have permission to open this file". This suggests that php5ts.dll has been created with the wrong permissions.
 [2013-12-18 16:05 UTC] michael at squiloople dot com
Replacing php5ts.dll with the version from 5.5.3 allows Apache to run 5.5.7, again suggesting that there is some fundamental permission error with the version starting 5.5.4 (the file cannot be opened or copied even when "run as administrator").
 [2013-12-20 11:28 UTC] michael at squiloople dot com
php5ts.dll was being blocked by AVG anti-virus (2011). Not sure if this qualifies as a bug or not so I won't close.
 [2013-12-21 13:44 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2013-12-21 13:44 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 17:01:28 2024 UTC