php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66297 Additional .ini files API in oneline (IE)
Submitted: 2013-12-15 16:09 UTC Modified: 2016-08-03 20:15 UTC
Votes:22
Avg. Score:4.8 ± 0.6
Reproduced:8 of 8 (100.0%)
Same Version:4 (50.0%)
Same OS:8 (100.0%)
From: dennis1993 at trash-mail dot com Assigned: cmb (profile)
Status: Wont fix Package: Unknown/Other Function
PHP Version: Irrelevant OS: Internet Explorer
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dennis1993 at trash-mail dot com
New email:
PHP Version: OS:

 

 [2013-12-15 16:09 UTC] dennis1993 at trash-mail dot com
Description:
------------
If I create this file:

<?php
phpinfo();
?>

it looks like this in Firefox: http://www7.pic-upload.de/15.12.13/tqmluatmzksk.png

The part "Additional .ibi files parsed" is correct.

In Internet Explorer it looks like this: http://www7.pic-upload.de/15.12.13/1qqaxmknt5.png

You can see, it is no line break. It is in PHP 5.2, 5.3, 5.4 and 5.5. I've tested it with IE 8, IE9, IE10 and IE11.

Where is the problem?
Can you fix it, maybe?

Thanks in advance!

Test script:
---------------
<?php
phpinfo();
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-30 20:21 UTC] aladin at web dot de
Can anyone reproduce it?
And is it fixable?

Thanks in advance!
 [2014-01-13 13:20 UTC] info at jingles4free dot de
Hello?
 [2014-01-15 17:59 UTC] maxi at php2 dot net
You do not want to help me?

I want to improve PHP yet. :(
Now I'm a bit sad.
 [2016-08-03 19:21 UTC] cmb@php.net
-Package: *General Issues +Package: Unknown/Other Function
 [2016-08-03 20:15 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2016-08-03 20:15 UTC] cmb@php.net
I can confirm the behavior. Obviously, Internet Explorer refuses
to break the line before a slash character, but other browsers,
including MS Edge do. Furthermore, such long lists of additional
ini files are most likely relevant for distros only, and for
Ubuntu the issue is solved at least as of 14.04 by choosing names
like `20-gd.ini`. Feel free to also use hyphens, as IE does also
break the line in this case.

Finally, to my knowledge, there is no adequate solution short of
adding table {word-break: break-all}, what yields otherwise
undesired results. Therefore I'm closing as won't fix.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 21:03:34 2021 UTC