php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66262 Bad output with the example #2 of manual page structures.goto (Spanish)
Submitted: 2013-12-11 10:45 UTC Modified: 2013-12-11 18:15 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: antonioj85 at gmail dot com Assigned: aharvey (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: Mac OS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: antonioj85 at gmail dot com
New email:
PHP Version: OS:

 

 [2013-12-11 10:45 UTC] antonioj85 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/control-structures.goto
---

Bad output with the example #2.

Correct output in "Expected result".

Expected result:
----------------
Ejemplo #2 Ejemplo de goto en un bucle

<?php
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    if($j==17) goto end;
  }  
}
echo "i = $i";
end:
echo 'j alcanzó 17';
?>
El resultado del ejemplo sería:

j alcanzó 17


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-11 18:15 UTC] aharvey@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: aharvey
 [2013-12-11 18:15 UTC] aharvey@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 02 22:03:49 2023 UTC