php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66253 !! overwritten code examples throughout whole website
Submitted: 2013-12-10 02:24 UTC Modified: 2015-01-03 11:02 UTC
Votes:5
Avg. Score:3.6 ± 1.5
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:2 (50.0%)
From: wayne dot david dot harris at gmail dot com Assigned: jacob (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wayne dot david dot harris at gmail dot com
New email:
PHP Version: OS:

 

 [2013-12-10 02:24 UTC] wayne dot david dot harris at gmail dot com
Description:
------------
Across the whole new website code examples overwrite because of incorrect css letterspacing/wordspacing for the monospace font

I have tested in Chrome and Firefox and still same problem

relevant CSS:

.refsect1 .dc-description, .refsect1 .dc-description code, .docs .sect1 .dc-description, .docs .sect1 .dc-description code {
font-weight: 400;
font-size: 16px;
font-family: "Source Code Pro", monospace;
letter-spacing: -.0625em;
word-spacing: -.125em;
margin: 0;
}


e.g in..
Constructors and Destructors
Constructor

*******************
void __construct ([ mixed $args [, $... ]] )   
**********************
** this line is completely overwritten scrambled. In the space of the word '__construct' the whole line overwrites to be totally unreadable


Very weird that no-one else is experiencing this..

Cheers
Wayne


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-11 18:15 UTC] email at philsturgeon dot co dot uk
Can you provide a URL to a page with this issue, and provide a screenshot of the issue as well?
 [2013-12-11 20:54 UTC] aharvey@php.net
-Status: Open +Status: Feedback -Package: Online Doc Editor problem +Package: Website problem
 [2013-12-11 22:56 UTC] wayne dot david dot harris at gmail dot com
-Summary: WEBSITE: overwritten code examples throughout whole website ! +Summary: !! overwritten code examples throughout whole website -Status: Feedback +Status: Open -Package: Website problem +Package: Online Doc Editor problem
 [2013-12-11 22:56 UTC] wayne dot david dot harris at gmail dot com
The scrambled text problem only occurs in CHROME for both standard and canary versions and strangley just on my Win7 desktop.

And happens throughout the whole site on any page with code on it.

But i viewed site on my win 7 laptop in Chrome and its fine.

I havnt had issue with any other site in Chrome on my desktop & i am at my pc all day working on it. But it seems theres something (not) configured on my desktop affecting display.

I wanted to upload screenshot images but how do i thru your site interface???
I tried adding an image as patch but it rejected. Am i missing something here?

Cheers
Wayne
 [2013-12-31 17:53 UTC] frozenfire@php.net
-Package: Online Doc Editor problem +Package: Website problem
 [2014-01-22 08:18 UTC] arjan at uprise dot nl
Same happens here on Chrome (32.0.1700.77) on Mac, OS X Mavericks (screenshot http://upload.uprise.nl/ob3j). Firefox and Safari are okay.

Problem occurred since I installed the Source Code Pro font.
 [2014-02-14 19:51 UTC] sdxqy at getairmail dot com
Arjan, you're a genius!  Thank you so much ... this was driving me crazy.  I closed Chrome, uninstalled the "Source Code Pro" font, and the site now displays correctly for me on Windows 7.  Yay!
 [2015-01-03 11:02 UTC] jacob@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: jacob
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 11:01:29 2024 UTC