php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #66154 http://us1.php.net/quickref.php not found
Submitted: 2013-11-22 23:19 UTC Modified: 2013-12-23 05:35 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: gary dot johnson dot 53 at gmail dot com Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gary dot johnson dot 53 at gmail dot com
New email:
PHP Version: OS:

 

 [2013-11-22 23:19 UTC] gary dot johnson dot 53 at gmail dot com
Description:
------------
http://us1.php.net/quickref.php resolves to search

It thought was a very useful page.

Test script:
---------------
http://us1.php.net/quickref.php

Expected result:
----------------
goes to http://us1.php.net/quickref.php

Actual result:
--------------
http://us1.php.net/search.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-23 00:55 UTC] bjori@php.net
Would it be better if it redirected to http://us1.php.net/manual/en/indexes.functions.php ?
 [2013-11-23 12:33 UTC] gary dot johnson dot 53 at gmai dot com
I personally would prefer this 
 http://us1.php.net/manual/en/indexes.functions.php 
over search.

One of the things I liked about the old quickref format is that it was easy to scan.  Lets say you do both perl and php, or net and php or javascript and php.
And you need string in string.  In some languages its index or subst or the fantastic strstr or stristr.  The function list is a pain to search for something like strings.   The indexes.functions.php is really comprehensive, but, in my mind, not as useful as the original quickref for finding basic functions.  I will probably not use more than 5% of the functions listed on indexes.functions.php.  I used a substantially higher percentage of the items on the quickref.  When quickref went away, I activated the Firefox PHP developer toolbar.  Unfortunately, the quick ref search no longer works.  

Thanks for all the work.  I would vote for keeping a version of quickref.
 [2013-11-23 20:49 UTC] bjori@php.net
I am little bit confused of how you think quickref.php used to work.

Are you talking about http://us3.php.net/manual-lookup.php?pattern=strpo&scope=quickref for example?

That is still available...

The quickref.php functionality that was removed was the full filename listing of the manual, which was insanely unbearably slow ofcourse.
The function index listing lists the same things, just using the documentation index file for *much* faster rendering along with the description of individual function - so is a drastic improvement.
 [2013-11-23 21:26 UTC] gary dot johnson dot 53 at gmail dot com
This : http://us1.php.net/quickref.php

use to generate a 3 column listing of the most commonly called functions. 

you can see a snapshot at http://archive.org/web/ if your enter the url
or 
I uploaded a screenshot to here http://garyjohnsoninfo.info/quickref.png

I think I confused the issue with 
When quickref went away, I activated the Firefox PHP developer toolbar.  Unfortunately, the quick ref search no longer works.  Its unrelated

Its really not that big a deal.  I work in a bunch of languages.  What I found helpful about the 3 column display was, often times I would review the list and I would be reminded,   "That's what php calls it".  ( as opposed to Javascipt, perl, python bash etc)
 [2013-11-23 22:00 UTC] bjori@php.net
Right, this list is the same as http://us1.php.net/manual/en/indexes.functions.php
Just not using 3columns, and actually lists all functions and methods (correctly).

The previous quickref list was based on filenames, which therefore was completely wrong for the vast majority of methods, and also missed a lot of functions (or methods) that are documented on the same page.
 [2013-12-04 12:13 UTC] krakjoe@php.net
So, is this a won't-fix or what ? It seems like it may be even more confusing to redirect to the old url, because the content has change.

If it's won't-fix can someone update, or update with a plan please ...
 [2013-12-04 15:47 UTC] gary dot johnson dot 53 at gmail dot com
Can you add a new page where you can display 3 columns
and do a filter of exclude / include

AMQPEnvelope
ArrayAcess
ArrayObject
CachingIterator
Cairo..
Cubrid..
db2
Event
EV..
fann..
ftp
Gearman...
Gmagick..
gmp
HaruDoc
HTTP..
hw_
ibase
ifx..
image
Imagick
Int..
Intl
Judy
KTagLib...
maxdb
Memcached..
Mongo...
MQ
Mysqli
Mysql
ncurses..
newt
OCI
OAUTH
oci..
odbc
openal
ovrimos...
PDF..
PDO..
pg..
Phar
posix
printer..
pspell
ps_...
px...
QucikHash
radius
Rar..
Recursive...
Reflection...
runkit
SAMC
SDO..
SOAP..
SOLR
SPHINX
SPL
SPI
SQLite..
stats_..
stream..
svn..
SWF..
SWish
sybase
Thread
tidy
Tokyo..
trader
UConverter
udm
V8..
Variant
Varnish.
Vpopmail
Weak...
win32...
wincache..
Xdif
XML..
xslt
YAF..
yaz..
zedn.
ZIP..
ZMQ..

In my mind, a lot of the above are separate, special purpose functions specific to a platform or library.
 [2013-12-23 05:35 UTC] bjori@php.net
-Status: Open +Status: Wont fix
 [2013-12-23 05:35 UTC] bjori@php.net
We have sooooo many different extension and function listing that we simply cannot add another one, sorry.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 19:01:29 2024 UTC