php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66135 PDO connection issue when trying to access a remote iSeries server
Submitted: 2013-11-21 08:04 UTC Modified: 2014-06-20 07:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: max dot rault at gmail dot com Assigned:
Status: Closed Package: PDO_IBM (PECL)
PHP Version: 5.4.16 OS: i5/OS V6R1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: max dot rault at gmail dot com
New email:
PHP Version: OS:

 

 [2013-11-21 08:04 UTC] max dot rault at gmail dot com
Description:
------------
Hello.

We've just installed Zend Server for IBMi 6.1 on one of our IBMi server and everything run OK. That said I'm faced to a problem I can't solve.

I wanted to make a DB2 connection test on the same server (LOOPBACK) but also on another IBMi server (REMOTE).

To make a summary of the issue, when I do a connection and a simple SQL query:
- by db2_connect --> everything's OK, LOCAL as REMOTE
- PDO_IBM (1.3.3)--> It does only work in LOCAL. Indeed the same query which work with db2_connect give us this error message (in french):

SQLSTATE[42971]: <<Unknown error>>: -7017 Unable to run statement with specified commit level. (SQLExecute[-7017] at /patched-php-src-5.4.16/php-5.4.16/ext/pdo_ibm/ibm_statement.c:1076)

I'm totally stuck and I really wanna use PDO for database access because a lot of PHP frameworks or open-source tools rest on PDO database access.

Thank for you help.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-21 08:07 UTC] max dot rault at gmail dot com
-PHP Version: 5.4.22 +PHP Version: 5.4.16
 [2013-11-21 08:07 UTC] max dot rault at gmail dot com
Zend Server comes with PHP 5.4.16.
 [2014-01-30 11:22 UTC] shlomo dot v at zend dot com
The error message refers to the DB commitment control, check your data base is using commitment control.

WRKJRN JRN(YOUR_LIB/*ALL)
Try to run the command ENDCMTCTL and test your script
GO CMDCMT - commit commands menu

SQLSTATE[42971]: <>: -7017 Unable to run statement with specified commit level.

SQL statements cannot be executed under commitment control, because commitment control is already active to another relational database.

DSPMSGD RANGE(SQL7017) MSGF(QSYS/QSQLMSG)
Message . . . . : Unable to run statement with specified commit level.
Cause . . . . . : SQL is unable to run the statement with the specified
commit level because SQL cannot register a resource with commitment control.
Recovery . . . : See previous messages for more information.
 [2014-06-20 07:51 UTC] max dot rault at gmail dot com
-Status: Open +Status: Closed
 [2014-06-20 07:51 UTC] max dot rault at gmail dot com
Problem solved after migrating to i5/OS V7R1.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Aug 13 03:05:44 2022 UTC