php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66056 mysql_connect(): Headers and client library minor version mismatch.
Submitted: 2013-11-08 07:17 UTC Modified: 2013-11-13 13:16 UTC
From: ihanick at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ihanick at gmail dot com
New email:
PHP Version: OS:

 

 [2013-11-08 07:17 UTC] ihanick at gmail dot com
Description:
------------
CentOS 6 with remi repository & ubuntu 13.04 having php-mysql extension compiled with libmysqlclient.so.18 library from mysql 5.5.

During 5.6 release mysql development team wasn't confirmed any major changes in library, thus just a minor library version bumped (5.5: libmysqlclient.so.18.0, 5.6: libmysqlclient.so.18.1).

Why we need major mysql version check in
./ext/mysql/php_mysql.c
./ext/mysqli/mysqli_nonapi.c
?

Currently it's not possible to deploy both libmysqlclient.so.18 libraries from 5.5 and & 5.6 in shared-compat package, because both versions are providing library file with the same major version.

Test script:
---------------
<?php
$link = mysql_connect('localhost', 'root', '');

Expected result:
----------------
Shouldn't produce any output

Actual result:
--------------
PHP Warning:  mysql_connect(): Headers and client library minor version mismatch. Headers:50534 Library:50614 in test-mysql.php on line 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-13 13:16 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-11-13 13:16 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

In the past there had been issues. Proper checking is quite complicated. We also suggest using mysqlnd-based instead of libmysql-based builds.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 16:04:40 2022 UTC