php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65944 File uploads over 2GB fail
Submitted: 2013-10-22 10:17 UTC Modified: 2013-10-22 12:03 UTC
From: jules at ecs dot soton dot ac dot uk Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.5.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jules at ecs dot soton dot ac dot uk
New email:
PHP Version: OS:

 

 [2013-10-22 10:17 UTC] jules at ecs dot soton dot ac dot uk
Description:
------------
File uploads over 2GB fail due to the file size being held in an int. File uploads over 4GB fail due to the file size being held in an unsigned int.


Patches

big-file-uploads (last revision 2013-10-22 10:18 UTC by jules at ecs dot soton dot ac dot uk)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-22 12:03 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-10-22 12:03 UTC] johannes@php.net
This was fixed for 5.6 dev versions and will be in an upcoming release.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 22:01:28 2024 UTC