php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6591 libphp4.sl is not a DSO
Submitted: 2000-09-07 04:42 UTC Modified: 2001-06-04 05:42 UTC
From: paolo dot berva at st dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.5 OS: HP-UX 10.20
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paolo dot berva at st dot com
New email:
PHP Version: OS:

 

 [2000-09-07 04:42 UTC] paolo dot berva at st dot com
I had the same problem also with the previous
version php-4.0.1pl2

./configure and make end without errors, but make install...

$ ./configure  \
  --with-pgsql=/opt/pgsql \
  --with-apxs=/opt/apache/bin/apxs \
  --without-mysql \
  --with-zlib=/opt/zlib \
  --with-config-file-path=/opt/apache/etc/httpd.conf \

$ make
$make install
...
Making install in .
        /opt/apache/bin/apxs -i -a -n php4 libs/libphp4.sl
apxs:Error: file libs/libphp4.sl is not a DSO
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.

Regards

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-01 09:49 UTC] sniper@php.net
reclassified
 [2000-11-23 18:18 UTC] sniper@php.net
Duplicate of #6052
 [2001-01-03 08:46 UTC] paolo dot berva at st dot com
Tried installing php 4.0.4 but with the same error.
I successfully installed php 4.0.4 using the workaround suggested by:

  marvin_lam@agilent.com

      It seems that apxs wants the shared library to be named
      libphp4.so, not libphp4.sl.  Do the following:
      # cp libs/libphp4.sl libs/libphp4.so
      # /path/to/bin/apxs -i -a -n php4 libs/libphp4.so

(Bug #7643)

Paolo
 [2001-06-04 05:42 UTC] paolo dot berva at st dot com
apache 1.3.20 doesn't fix the problem

Paolo
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 07:05:45 2022 UTC