php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65900 array_search doesn't work with mixed array
Submitted: 2013-10-15 14:53 UTC Modified: 2013-10-15 17:16 UTC
From: abhinavjpenmetsa at gmail dot com Assigned:
Status: Not a bug Package: Arrays related
PHP Version: Irrelevant OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: abhinavjpenmetsa at gmail dot com
New email:
PHP Version: OS:

 

 [2013-10-15 14:53 UTC] abhinavjpenmetsa at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.array-search#refsect1-function.array-search-returnvalues
---
try the below code

Test script:
---------------
$array = array(5,0,'green',9);
$needle = 'green';
var_dump(array_search($needle, $array));

Expected result:
----------------
int(2)

Actual result:
--------------
int(1)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-15 17:16 UTC] nikic@php.net
-Status: Open +Status: Not a bug -Package: Output Control +Package: Arrays related
 [2013-10-15 17:16 UTC] nikic@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You have not specified the $strict parameter of array_search, so the comparison is done using ==. As 0 == 'green' that is the element that's found. If you want type-strict comparison pass true as the last parameter.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 26 05:01:24 2020 UTC