php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #65829 Update to ICU 52.1 / Lao Word Boundary Support
Submitted: 2013-10-04 10:33 UTC Modified: 2013-10-30 13:39 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: robert dot rcampbell at gmail dot com Assigned: ab (profile)
Status: Closed Package: *Languages/Translation
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: robert dot rcampbell at gmail dot com
New email:
PHP Version: OS:

 

 [2013-10-04 10:33 UTC] robert dot rcampbell at gmail dot com
Description:
------------
Request update to ICU 52.1 after October 9th, 2013, so that the Lao language can use the boundary analysis available to PHP - need it for word-wrapping in Lao.

Thanks!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-04 13:45 UTC] pajoye@php.net
-Assigned To: +Assigned To: ab
 [2013-10-04 13:45 UTC] pajoye@php.net
I suppose you mean on windows right? As for any other OSes, you can install whatever the distribution provides, or manually compile the version you wish.

@a can you look to update to 5.1 for 5.5+? For what I see we have 5.0.
 [2013-10-05 18:10 UTC] robert dot rcampbell at gmail dot com
Good to know on other OSes. Will test it and check that it vorks...
 [2013-10-11 06:27 UTC] ab@php.net
-Status: Assigned +Status: Feedback
 [2013-10-11 06:27 UTC] ab@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.5-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2013-10-19 04:05 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2013-10-30 05:18 UTC] robert dot rcampbell at gmail dot com
Looks like there may a bug in the PHP Intl code, after I downloaded and tested the latest PHP / PHP Intl (PECL). Got a Java version of it to work fine (based on icu4j). Someone else (cataphract) was able to get a C++ version working. Here's my script:
<?php
if (!extension_loaded('intl'))
   die('skip intl extension not enabled');
ini_set("intl.error_level", E_WARNING);
ini_set("intl.default_locale", "lo_LA");
echo INTL_ICU_VERSION;
$bi = IntlBreakIterator::createWordInstance('lo');
$myText =
"ພຣະທັມເຮັບເລີຄາດຄະເນລ່ວງໜ້າວ່າຄົນຈະຮູ້ແລະເຂົ້າໃຈເຖິງວຽກງານຂອງປະໂລຫິດໃນສະໄໝຂອງຊົນຊາດອິດສະລາເອນເພື່ອວ່າຜູ້ທີ່ຮັບຈົດໝາຍທີ່ຖືກບັນທຶກໄວ້ໃນພຣະທັມນີ້ຈະສາມາດເຂົ້າໃຈວ່າພຣະເຢຊູຊົງເຮັດສິ່ງໃດສຳລັບພວກເຂົາໃນສະຫວັນ";
$bi->setText($myText);
var_dump($bi->first());
var_dump($bi->next());
var_dump($bi->next());
var_dump($bi->next());
var_dump($bi->next());
var_dump($bi->next());
var_dump($bi->next());
?>

PHP Output:
52.1
int 0
int 597
int -1
int -1
int -1
int -1
int -1
 [2013-10-30 12:49 UTC] ab@php.net
-Status: No Feedback +Status: Closed
 [2013-10-30 12:49 UTC] ab@php.net
The windows ICU version was upgraded to 51.2, you can get it from the snap http://windows.php.net/downloads/snaps/php-5.5/ (take one of the latest). As you use the PECL version, could you please decouple your report into a separate ticket and assign it to the PECL intl ext. As this ticket was about upgrading the ICU for the windows builds and it's done. Please give then which exact PHP version, platform, etc you've used to reproduce the wrong behavior, and what's the correct result you expect. With the intl ext in the core results might differ.

Thanks
 [2013-10-30 13:39 UTC] robert dot rcampbell at gmail dot com
Done. New bug submitted #66002 for PECL intl. Will test the Windows Snapshot on my Windows XP tomorrow. Thanks so much for your help!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 09:01:24 2020 UTC