php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65817 curl extension not visible after executing get_loaded_extensions()
Submitted: 2013-10-02 18:06 UTC Modified: 2013-10-02 21:47 UTC
From: forsoap at gmail dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.5.4 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: forsoap at gmail dot com
New email:
PHP Version: OS:

 

 [2013-10-02 18:06 UTC] forsoap at gmail dot com
Description:
------------
In php.ini I uncommented string:
extension=php_curl.dll

When I run php -m, it shows in list curl, but when I try use get_loaded_extensions() in any php file it not in list. Also I am using php as an module in Apache 2.4 and problem can be reproduced if php loads as module in apache


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-02 21:47 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-10-02 21:47 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Apparently apache can't load it. This might have different reasons. i.e. apache miht use a different php.ini or different PHP version. There might also be permission or other system level reasons. Check your logs etc.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 22:01:34 2019 UTC