php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65813 Reference For Cross-Platform Compatible Code when connecting to MSSQL
Submitted: 2013-10-02 15:23 UTC Modified: 2020-03-14 17:02 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: admin at jaypoc dot com Assigned: cmb (profile)
Status: Closed Package: sqlsrv (PECL)
PHP Version: 5.4.20 OS: Linux/Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at jaypoc dot com
New email:
PHP Version: OS:

 

 [2013-10-02 15:23 UTC] admin at jaypoc dot com
Description:
------------
There's no information/reference for developers who need PHP/MS SQL sites to function on both Linux/OSX based servers as well as Windows/IIS servers. Refernce to cross platform DB interfaces or compatible modules would be helpful.

---
From manual page: http://www.php.net/intro.mssql
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-02 18:50 UTC] aharvey@php.net
-Package: MSSQL related +Package: sqlsrv
 [2013-10-02 18:50 UTC] aharvey@php.net
I'm not sure we can do this sensibly, to be honest, given the recommended drivers are different cross-platform (sqlsrv on Windows, ODBC on everything else, as far as I know).

Let's pop this onto the sqlsrv radar: do you guys have any thoughts on this (or documentation we can use, or at least link to)?
 [2013-10-02 18:57 UTC] gabri dot ns at gmail dot com
since microsoft provide source code for this extension,
is it not possible for other platform to compile this?
 [2020-02-07 14:57 UTC] cmb@php.net
-Summary: Reference For Cross-Platform Compatable Code when connecting to MSSQL +Summary: Reference For Cross-Platform Compatible Code when connecting to MSSQL -Status: Open +Status: Verified
 [2020-02-07 14:57 UTC] cmb@php.net
The Microsoft Drivers for PHP for SQL Server[1] are
cross-platform.  Our documentation should be updated in this
regard.

[1] <https://github.com/microsoft/msphpsql>
 [2020-03-14 17:02 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=349429
Log: Fix #65813: Reference For Cross-Platform Compatible Code when connecting to MSSQL

The reference to SQLSRV is already there, but the info that the SQLSRV drivers
are for Windows only is outdated.
 [2020-03-14 17:02 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2020-03-14 17:02 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-03-14 17:04 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=21c6f827cd3756c67299fd0f5286eb694f8edb10
Log: Fix #65813: Reference For Cross-Platform Compatible Code when connecting to MSSQL
 [2020-03-14 22:55 UTC] mumumu@php.net
Automatic comment from SVN on behalf of mumumu
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=349439
Log: Fix #65813: Reference For Cross-Platform Compatible Code when connecting to MSSQL

The reference to SQLSRV is already there, but the info that the SQLSRV drivers
are for Windows only is outdated.
 [2020-03-14 23:00 UTC] phpdocbot@php.net
Automatic comment on behalf of mumumu
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=831ae8e60a96cfb494382eb37203b274ae46f9a1
Log: Fix #65813: Reference For Cross-Platform Compatible Code when connecting to MSSQL
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 04:01:26 2020 UTC