php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65810 PHP treats integer 0 as a NULL
Submitted: 2013-10-02 11:15 UTC Modified: 2013-10-02 11:31 UTC
From: gnjagi at gmail dot com Assigned:
Status: Not a bug Package: Doc Build problem
PHP Version: Irrelevant OS: win 7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gnjagi at gmail dot com
New email:
PHP Version: OS:

 

 [2013-10-02 11:15 UTC] gnjagi at gmail dot com
Description:
------------
PHP is treating integer 0 as a NUll. This brings inconsistency when dealing with an array with zeros and spaces(NULL)

Test script:
---------------
$val==0;
if ($val==NULL)
{
echo "sad";
}

Expected result:
----------------
No value

Instead it returns "sad"

Actual result:
--------------
"sad"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-02 11:31 UTC] mike@php.net
-Status: Open +Status: Not a bug -Package: *Compile Issues +Package: Doc Build problem
 [2013-10-02 11:31 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 17:01:26 2020 UTC