php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65802 Segmentation fault on creating new SoapClient
Submitted: 2013-10-01 16:25 UTC Modified: 2013-10-02 13:56 UTC
From: karen dot thompkins at americanlanternpress dot com Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.4.20 OS: Linux version 2.6.32-279.5.2.el6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: karen dot thompkins at americanlanternpress dot com
New email:
PHP Version: OS:

 

 [2013-10-01 16:25 UTC] karen dot thompkins at americanlanternpress dot com
Description:
------------
Script ran fine until early this morning when cPanel ran its nightly update. I am unable to track down what might be causing the issue.

Configure: Command 	'./configure' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-zip' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-gd' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr' 

cURL support 	enabled
cURL Information 	7.24.0
Age 	3
Features
AsynchDNS 	No
Debug 	No
GSS-Negotiate 	No
IDN 	Yes
IPv6 	Yes
Largefile 	Yes
NTLM 	Yes
SPNEGO 	No
SSL 	Yes
SSPI 	No
krb4 	No
libz 	Yes
CharConv 	No
Protocols 	dict, file, ftp, ftps, gopher, http, https, imap, imaps, pop3, pop3s, rtsp, smtp, smtps, telnet, tftp
Host 	x86_64-unknown-linux-gnu
SSL Version 	OpenSSL/1.0.0
ZLib Version 	1.2.3 

libxml
libXML support 	active
libXML Compiled Version 	2.9.0
libXML Loaded Version 	20900
libXML streams 	enabled 

soap
Soap Client 	enabled
Soap Server 	enabled

Directive	Local Value	Master Value
soap.wsdl_cache	1	1
soap.wsdl_cache_dir	/tmp	/tmp
soap.wsdl_cache_enabled	1	1
soap.wsdl_cache_limit	5	5
soap.wsdl_cache_ttl	86400	86400

Test script:
---------------
$wsdl = "https://api.verticalresponse.com/wsdl/1.0/VRAPI.wsdl"; //location of the wsdl
$vr = new SoapClient($wsdl,
 array (
    // 'local_cert' => $cert,
    // 'passphrase' => $cert_pass
	)
);

Expected result:
----------------
Soap client assigned to variable

Actual result:
--------------
Segmentation fault

# gdb php
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-56.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/bin/php...done.
(gdb) run vr.php
Starting program: /usr/local/bin/php vr.php
warning: the debug information found in "/usr/lib/debug//usr/lib64/libfreebl3.so.debug" does not match "/usr/lib64/libfreebl3.so" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/usr/lib64/libfreebl3.so.debug" does not match "/usr/lib64/libfreebl3.so" (CRC mismatch).

Missing separate debuginfo for /usr/lib64/libfreebl3.so
Try: yum --disablerepo='*' --enablerepo='*-debug*' install /usr/lib/debug/.build-id/68/195872ecfb188389d29aaf01031a976fd18168.debug
[Thread debugging using libthread_db enabled]


Program received signal SIGSEGV, Segmentation fault.
memcpy () at ../sysdeps/x86_64/memcpy.S:422
422             movq    16(%rsi), %r9
Missing separate debuginfos, use: debuginfo-install libXau-1.0.5-1.el6.x86_64 libidn-1.18-2.el6.x86_64 libtool-ltdl-2.2.6-15.5.el6.x86_64 libxcb-1.5-1.el6.x86_64
(gdb) bt
#0  memcpy () at ../sysdeps/x86_64/memcpy.S:422
#1  0x000000000063f58f in sdl_deserialize_string (in=0x7fffffffa210) at /home/cpeasyapache/src/php-5.4.20/ext/soap/php_sdl.c:1208
#2  0x0000000000644274 in sdl_deserialize_type (type=0x7ffff0640488, types=0x7ffff062bc68, encoders=0x7ffff063add8, in=0x7fffffffa210)
    at /home/cpeasyapache/src/php-5.4.20/ext/soap/php_sdl.c:1329
#3  0x00000000006443ac in sdl_deserialize_type (type=0x7ffff063aa18, types=0x7ffff062bc68, encoders=0x7ffff063add8, in=0x7fffffffa210)
    at /home/cpeasyapache/src/php-5.4.20/ext/soap/php_sdl.c:1378
#4  0x000000000064accf in get_sdl_from_cache (this_ptr=<value optimized out>, uri=0x7ffff74ac360 "https://api.verticalresponse.com/wsdl/1.0/VRAPI.wsdl",
    cache_wsdl=<value optimized out>) at /home/cpeasyapache/src/php-5.4.20/ext/soap/php_sdl.c:1642
#5  get_sdl (this_ptr=<value optimized out>, uri=0x7ffff74ac360 "https://api.verticalresponse.com/wsdl/1.0/VRAPI.wsdl", cache_wsdl=<value optimized out>)
    at /home/cpeasyapache/src/php-5.4.20/ext/soap/php_sdl.c:3250
#6  0x000000000061aa7d in zim_SoapClient_SoapClient (ht=2, return_value=<value optimized out>, return_value_ptr=<value optimized out>,
    this_ptr=0x7ffff75b5748, return_value_used=<value optimized out>) at /home/cpeasyapache/src/php-5.4.20/ext/soap/soap.c:2512
#7  0x00007ffff13745af in xdebug_execute_internal (current_execute_data=0x7ffff757c060, return_value_used=0) at /root/tmp/pear/xdebug/xdebug.c:1547
#8  0x00000000007f3c05 in zend_do_fcall_common_helper_SPEC (execute_data=<value optimized out>)
    at /home/cpeasyapache/src/php-5.4.20/Zend/zend_vm_execute.h:645
#9  0x00000000007e7d20 in execute (op_array=0x7ffff75b29c8) at /home/cpeasyapache/src/php-5.4.20/Zend/zend_vm_execute.h:410
#10 0x00007ffff1374a09 in xdebug_execute (op_array=0x7ffff75b29c8) at /root/tmp/pear/xdebug/xdebug.c:1435
#11 0x000000000077eaad in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /home/cpeasyapache/src/php-5.4.20/Zend/zend.c:1317
#12 0x0000000000722827 in php_execute_script (primary_file=0x7fffffffdc30) at /home/cpeasyapache/src/php-5.4.20/main/main.c:2502
#13 0x0000000000829d8c in do_cli (argc=2, argv=0x7fffffffe038) at /home/cpeasyapache/src/php-5.4.20/sapi/cli/php_cli.c:989
#14 0x000000000082a508 in main (argc=2, argv=0x7fffffffe038) at /home/cpeasyapache/src/php-5.4.20/sapi/cli/php_cli.c:1365


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-02 01:04 UTC] felipe@php.net
I can't reproduce it, are you able to reproduce it without local_cert' and 'passphrase' data?
 [2013-10-02 01:04 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2013-10-02 12:35 UTC] karen dot thompkins at americanlanternpress dot com
Those lines are commented out.  I apologize, I should have removed them before I pasted the code in.
 [2013-10-02 13:55 UTC] karen dot thompkins at americanlanternpress dot com
Today the issue seems to have disappeared. Unsure what caused it to break and what caused it to be fixed.
 [2013-10-02 13:56 UTC] karen dot thompkins at americanlanternpress dot com
-Status: Feedback +Status: Closed
 [2013-10-02 13:56 UTC] karen dot thompkins at americanlanternpress dot com
Issue appears to be resolved.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 19:01:29 2024 UTC