php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65669 setup fail
Submitted: 2013-09-13 17:46 UTC Modified: 2013-09-13 18:04 UTC
From: pennyzenny at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.4.20RC1 OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pennyzenny at gmail dot com
New email:
PHP Version: OS:

 

 [2013-09-13 17:46 UTC] pennyzenny at gmail dot com
Description:
------------
I have installed apache 2.2, php 5.3.27 and MySQL notifier 1.1.4 and what ever version of MySQL comes with that as it didn't say anywhere what version it is, I guess another bug.

php 5.3.27 seems to be the only version for windows binaries.

I have used several versions of apache, php and MySQL over the years.

I have spent hours trying to get the current 3 to work.

apache2.2 works fine.

php works fine.

every time I add PHPinidir to the httpd.conf file php stops working, why do all the setup guides tell me to do this????

I have followed endless guides to configure MySQL to work in php but none of them work.

I always get...

Fatal error: Call to undefined function mysqli_connect() in C:\PROJECT\www\index.php on line 26

same if I try mysql_connect() but I believe that is no longer used.

EVERYTIME I SEARCH TO FIND A GUIDE TO SETUP PHP TO USE MYSQL ALL I FIND ARE LINKS TO PAGES AND PAGES OF WAFFLE ABOUT A LOAD OF SHIT AND NO DETAILS HOW TO CONFIURE PHP... SORT IT OUT!!!

I downloaded phpmailer5.1 and this is what I get...

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for '1.0/DST' instead in C:\PROJECT\www\class.phpmailer.php on line 1925

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for '1.0/DST' instead in C:\PROJECT\www\class.phpmailer.php on line 1929

Fatal error: Uncaught exception 'phpmailerException' with message 'SMTP Error: Could not connect to SMTP host.' in C:\PROJECT\www\class.phpmailer.php:820 Stack trace: #0 C:\PROJECT\www\class.phpmailer.php(705): PHPMailer->SmtpConnect() #1 C:\PROJECT\www\class.phpmailer.php(576): PHPMailer->SmtpSend('Date: Fri, 13 S...', 'This is a test ...') #2 C:\PROJECT\www\index.php(23): PHPMailer->Send() #3 {main} thrown in C:\PROJECT\www\class.phpmailer.php on line 820



WHY CANT ANYONE MAKE SOMETHING THAT BLOODY WELL WORKS INSTEAD OF TRYING TO PASS OFF A LOAD OF SHIT AS THE LATEST AND BESTEST VERSION?????








Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-13 18:04 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2013-09-13 18:04 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Try going with WampServer - a bundle of Apache, MySQL, and PHP that should be 
easier to install and manage. Be sure to remove whatever you've installed first so 
you don't have two different copies of Apache and PHP.
http://www.wampserver.com/en/

As for the PHPMailer error, it's looking for an "MTA" (mail transfer agent, which 
coordinates sending emails) on your computer but desktop versions of Windows do 
not have those by default. You can find and install one, or better yet set up 
PHPMailer to send from your GMail account instead.
http://stackoverflow.com/a/9776379
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 19:05:46 2022 UTC