|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65655 Trouble posting to Internals ML with custom domains
Submitted: 2013-09-11 16:49 UTC Modified: 2013-10-15 11:54 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: phil at philsturgeon dot co dot uk Assigned: danbrown (profile)
Status: No Feedback Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: phil at philsturgeon dot co dot uk
New email:
PHP Version: OS:


 [2013-09-11 16:49 UTC] phil at philsturgeon dot co dot uk
I signed up in the past with and several times over the 
course of months tried to post to the internals mailing list with no success. 

Dan Brown suggested I tried another email on the same domain, but after 
subscribing with phil@... no posts were happening either.

I then tried subscribing with an old gmail address and following the exact same 
process, with the exact same client (Gmail Plain-Text mode) as I had tried with 
all three emails - this way worked:


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-11 17:10 UTC] dan at dancryer dot com
For reference, this also happens to me. I use google apps for and 
my emails do not get submitted to the list.
 [2013-09-11 20:10 UTC]
-Status: Open +Status: Assigned -Assigned To: +Assigned To: danbrown
 [2013-09-11 20:10 UTC]
Assigning to Dan, since he was looking into it on IRC earlier.

For the record, I've never had trouble with a Google Apps account, so I don't 
think it's likely to be specifically that.
 [2013-09-11 20:10 UTC]
-Package: Website problem +Package: Systems problem
 [2013-09-12 11:33 UTC] narf at devilix dot net
Well, it does work: (same thread as the one originally posted)

However, my TXT record for SPF looks a bit differently than the one for ...
    v=spf1 ~all
    v=spf1 a mx ~all

Additionally, I have another TXT record for DKIM, which is missing for (or at least not pointing to google._domainkey.<domainname.tld>).
Instructions for that one can be found in Google Apps->Gmail->Authenticate Email.

With that being said though, this doesn't mean that all email addresses under the domain are invalid AND the majority of people using custom domains on Google probably haven't taken the time to configure every _optional_ feature like me, simply because their emails work just fine without additional efforts.
 [2013-09-12 17:04 UTC] email at philsturgeon dot co dot uk
That email you replied to was from my @gmail account not the 

I've added that extra TXT record so I'll wait for it to propagate and see if it 
helps out.
 [2013-09-12 17:14 UTC] narf at devilix dot net
Well, yes I noticed that. It's my email that the reply was successful from and it is hosted on Google Apps as well. :)
 [2013-10-01 20:05 UTC]
I'm able to communicate with the mailing lists using Gmail with addresses verified as send-as addresses.  However, the domains I've used do not have SPF records.  When checking your domain, I see the following TXT:

v=spf1 a mx ~all 

Since your MX is all Google for receipt, and you're likely using either Google or your own SMTP server, just to improve your own email, you should update your SPF record to reflect the host names.
 [2013-10-01 20:07 UTC]
-Status: Assigned +Status: Feedback
 [2013-10-01 20:07 UTC]
And I just now realized I had been on the "commits" tab and didn't see the conversation in the comments here.  Looks like everyone's on the same page (except the TXT still hasn't updated).
 [2013-10-01 20:11 UTC]
FWIW, I've had some problems with gmail and custom domains on a server whose network doesn't speak IPv6 somewhere upstream (the server itself does).

ASPMX.L.GOOGLE.COM (the MX-0 for is:

ASPMX.L.GOOGLE.COM has address
ASPMX.L.GOOGLE.COM has IPv6 address 2607:f8b0:400d:c01::1b

I'm not saying this is necessarily the problem, but it might be worth looking into if the TXT thing isn't the solution.

 [2013-10-15 11:54 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Dec 10 13:01:26 2023 UTC