php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65532 Recommendation to remove undocumented configuration directives
Submitted: 2013-08-22 22:52 UTC Modified: 2013-10-03 05:50 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: cevfora at elitemail dot org Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cevfora at elitemail dot org
New email:
PHP Version: OS:

 

 [2013-08-22 22:52 UTC] cevfora at elitemail dot org
Description:
------------
PROBLEM: 

The page titled "List of php.ini directives" at 

http://www.php.net/manual/en/ini.list.php

includes directives lacking documentation such as 

axis2.*
birdstep.max_links
coin_acceptor.*
daffodildb.*
imlib2.*
intl.*
ircg.*
pam.servicename
python.*
simple_cvs.*
uploadprogress.file.filename_template 
valkyrie.*
velocis.max_links 
vld.*
xmms.*
yami.response.timeout

These directives

A) lack links to documentation, and
B) have no corresponding PHP extensions listed on the page

http://www.php.net/manual/en/extensions.alphabetical.php

where the extension name would be implied from the configuration directive name of the form <extension name>.<parameter>  (e.g. pam.servicename implies extension "pam").

Moreover, PECL does not have packages with the names birdstep, ircg, velocis, simple_cvs) according to searches at 

http://pecl.php.net/package-search.php


RECOMMENDATION:

A) Remove these directives from the page "List of php.ini directives" and no longer make an effort to document them on www.php.net.

or ...

B) Remove these directives from the page "List of php.ini directives" and move them to a new page (e.g. "Directives Formerly Documented on www.php.net").

or ...

C) Retain these directives on the page "List of php.ini directives" and provide links to a page that informs the programmer seeking documentation that the corresponding PHP extensions are no longer being documented at php.net.


OPINION:

The following are my opinions on these 3 possible solutions.  I recognize that others may have different, and more enlightened insight into the realities of documenting a list of configuration directives that continues to evolve. 

Solution A is cleanest; if a directive is listed, then it is documented.

Solution B could provide a resource for the programmer who asks "What happened to the directive I used 8 years ago that appears to be missing?".  

Solution C inelegantly combines directives currently documented on www.php.net with directives no longer adequately documented on the site.  Over time the list of directives may grow with the undocumented directives becoming a larger fraction of the total set of listed directives, diluting the value of the list. The programmer would find no clear documentation of why some configuration directive "remnants" are left in the list while many other extensions (as provided in numerous PECL packages) are not documented at all. 





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-03 05:50 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-03 05:50 UTC] krakjoe@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

The INI list is not meant to function as a sitemap, it is meant to provide an exhausting list, it does not necessarily have to link to other manual pages for every option on the page.

I have removed the old extensions from the ini list.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC