php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65521 No documentation of MSSQL configuration directives
Submitted: 2013-08-22 18:19 UTC Modified: 2013-10-03 06:16 UTC
From: cevfora at elitemail dot org Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cevfora at elitemail dot org
New email:
PHP Version: OS:

 

 [2013-08-22 18:19 UTC] cevfora at elitemail dot org
Description:
------------

a) The page titled "Runtime Configuration" for extension "MSSQL" 

http://www.php.net/manual/en/mssql.configuration.php

is missing explanations of the directives mssql.*.  The provided default values are insufficient documentation for the impact of setting these directives.

b) These directives require links from the page titled "List of php.ini directives" at

http://php.net/manual/en/ini.list.php

where the directives are listed to the supplied explanations.





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-03 06:16 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-03 06:16 UTC] krakjoe@php.net
The INI list is not meant to function as a sitemap, it is meant to provide an exhaustive list of options, but does not necessarily have to link to manual pages foreach option.

It is sufficient that the options are listed somewhere, regrettable as it is, some extensions have options that the authors do not want to expose to every user, so they choose to document it partly or not at all.

While we might have experience with some extensions, the documentation team do not have enough experience with every extension to make calls on what should and should not be included, or more specifically where it should be included.

We do try to keep ini.list complete and relevant, but the configuration section for any one extension, is not required to be exhaustive, and may leave out options for the users own benefit. There are no general rules that we can apply.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 12 14:01:35 2024 UTC