php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #65491 openssl version requirements incorrectly listed
Submitted: 2013-08-21 04:04 UTC Modified: 2013-08-21 19:26 UTC
From: zelnaga at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 - 18 = ?
Subscribe to this entry?

 
 [2013-08-21 04:04 UTC] zelnaga at gmail dot com
Description:
------------
Quoting pajoye@php.net at <https://bugs.php.net/bug.php?id=55470&edit=3>, "[PHP] can't update to 1.0.0 [of OpenSSL] yet". And yet <http://us2.php.net/manual/en/openssl.requirements.php> says that PHP >= 4.3.2 can use OpenSSL >= 0.9.6.

Last I checked 1.0.0 >= 0.9.6. If 1.0.0 cannot be used the documentation should be updated to reflect that.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-21 19:26 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Type: Bug +Type: Documentation Problem
 [2013-08-21 19:26 UTC] aharvey@php.net
Pierre is just referring to the binary Windows builds there, I believe. PHP 
(including 5.3) builds just fine against OpenSSL 1.0.0+.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri May 14 17:01:23 2021 UTC