php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65476 php_gettext.dll will not load
Submitted: 2013-08-19 07:37 UTC Modified: 2013-08-19 10:47 UTC
From: mastermnd at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.5.2 OS: Windows 7 x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mastermnd at gmail dot com
New email:
PHP Version: OS:

 

 [2013-08-19 07:37 UTC] mastermnd at gmail dot com
Description:
------------
I am on Windows 7 x64 Ultimate, running Apache 2.4.6 VC11 x64 from the apache lounge with PHP 5.5.2 x64 TS from windows.php.net. With PHP versions 5.5.1 and 5.5.2, I get the following error when starting:

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\bin\\ts\\ext\\php_gettext.dll' - The specified module could not be found.\r\n in Unknown on line 0

Needless to say, the DLL exists in the right path, permissions are ok [other modules work fine!]

If I load alternative config files and start PHP 5.5.2 x64 NTS with mod_fcgi 2.3.7, then php_gettext.dll loads fine.

I am reporting this because I suspect there is a compilation or packaging issue with the TS version. Alternatively, the DLL might have a new dependency that i'm not aware of? iconv.dll or similar that is missing?

Regards.

Test script:
---------------
I am using a copy of php-production.ini with the following modules list (in this order):

zend_extension="C:\php\bin\ts\php_xdebug-2.2.3-5.5-vc11-x86_64.dll"
extension=php_mbstring.dll
extension=php_bz2.dll
extension=php_curl.dll
extension=php_fileinfo.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_openssl.dll
extension=php_pdo_mysql.dll
extension=php_soap.dll


Expected result:
----------------
I should be able to load the module but I can't.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-19 07:53 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2013-08-19 07:53 UTC] pajoye@php.net
works just fine.

C:\temp\5.5.2nts>php -d extension_dir=ext -d extension=php_gettext.dll -m
[PHP Modules]
bcmath
calendar
Core
ctype
date
dom
ereg
filter
ftp
gettext
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

Be sure to have set your php.ini path correctly, as well as the PATH variable 
(so all required DLL can be loaded as well).
 [2013-08-19 08:25 UTC] mastermnd at gmail dot com
Sorry but if you are running the command from 
C:\temp\5.5.2nts> you probably haven't read my report carefully.

My path is set up correctly, since all other extensions load fine, and so is my config. Previous versions of PHP were loading the extesion just fine too. If i change both apache and php to 32-bit, the extension also loads. It's only 64bit *thread-safe* (mod-php) that shows this behaviour.
 [2013-08-19 08:29 UTC] mastermnd at gmail dot com
By the way, I just redownloaded 5.5.0, and using exactly THE SAME config, gettext loads fine. It's definitely a problem in 5.5.1 and 5.5.2
Up to you if you prefer to ignore it.
 [2013-08-19 08:43 UTC] pajoye@php.net
-Status: Not a bug +Status: Feedback
 [2013-08-19 08:43 UTC] pajoye@php.net
I do not want to ignore it but can't really help with setup questions.

Tested TS-x64:

C:\temp\5.5.2tsx64>php -d extension_dir=ext -d extension=php_gettext.dll -m
[PHP Modules]
bcmath
calendar
Core
ctype
date
dom
ereg
filter
ftp
gettext
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

Something is wrong in your setup, maybe some incompatible DLLs are being 1st in 
the PATH. Can you try in CLI as well please?
 [2013-08-19 10:36 UTC] mastermnd at gmail dot com
My apologies, apparently some 3rd party program installed 32bit gettext libraries under some path under c:\windows which was taking precedence in the path. FastCGI had no problems because it redefines its own variables instead of relying on those set by windows. I created a new user and hardcoded its PATH and everything worked. 

Why this worked with 5.5.0 and not with 5.5.[1-2] makes absolutely no sense to me, but there you have it.

Please close this ticket.
Regards
 [2013-08-19 10:47 UTC] pajoye@php.net
-Status: Feedback +Status: Not a bug
 [2013-08-19 10:47 UTC] pajoye@php.net
setup issue
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 12:01:28 2024 UTC