php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65437 "Cannot redeclare function" alerts only when is used
Submitted: 2013-08-12 12:38 UTC Modified: 2013-08-12 13:38 UTC
From: joni2back at gmail dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joni2back at gmail dot com
New email:
PHP Version: OS:

 

 [2013-08-12 12:38 UTC] joni2back at gmail dot com
Description:
------------
PHP throws fatal error only when the duplicate function is called.


Test script:
---------------
Fatal error:
    function php()
    {
        function php()
        {
        }
    }
    php();

******

Nothing:
    function php()
    {
        function php()
        {
        }
    }

Expected result:
----------------
PHP should notify this problem (duplicate function) regardless the explicit call 
of the function

Actual result:
--------------
PHP does not notify if the duplicate function is not used

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-12 13:38 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-08-12 13:38 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You can define functions conditionally in PHP:

<?php
function a() {
  function b() {}
}

var_dump(function_exists('b'));
a();
var_dump(function_exists('b'));
?>
bool(false)
bool(true)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 12:01:25 2020 UTC