php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65426 DBA fails to compile with DB 6.0
Submitted: 2013-08-09 07:24 UTC Modified: 2013-12-03 12:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: pierre at archlinux dot de Assigned:
Status: Wont fix Package: DBM/DBA related
PHP Version: 5.5.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pierre at archlinux dot de
New email:
PHP Version: OS:

 

 [2013-08-09 07:24 UTC] pierre at archlinux dot de
Description:
------------
Compiling PHP with DB 6.0.20 fails with:

checking for DB4 major version... configure: error: Header contains different version

It just seems to affect the test of the configure script; the API is probably the same.

I have attached a patch that makes PHP work with DB 6. This might not be the correct way to solve this issue though.


Patches

db6.patch (last revision 2013-08-09 07:24 UTC by pierre at archlinux dot de)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-08-09 08:18 UTC] mike@php.net
I've limited knowledge of licensing, but BDB 6 is licensed under GNU AGPL v3.  
Looks like a problem.
 [2013-08-10 09:52 UTC] pierre at archlinux dot de
Thanks for te hint. You are probably right. I guess BDB support needs to be dropped in the long run unless someone continues to maintain DB5.
 [2013-12-03 12:46 UTC] mike@php.net
-Status: Open +Status: Wont fix
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 13:01:23 2020 UTC