php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65379 doesn't work because in php5.4.x there's no zend_class_entry anymore
Submitted: 2013-08-02 10:48 UTC Modified: 2017-04-01 19:38 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: m4t1k at interia dot pl Assigned:
Status: Wont fix Package: bloomy (PECL)
PHP Version: 5.4.17 OS: Debian 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
35 + 16 = ?
Subscribe to this entry?

 
 [2013-08-02 10:48 UTC] m4t1k at interia dot pl
Description:
------------
Package doesn't install on php5.4.4.

Result:
pecl install channel://pecl.php.net/bloomy-0.1.0

running: make
/bin/bash /tmp/pear/temp/pear-build-roothDvAr2/bloomy-0.1.0/libtool --mode=compile cc  -I. -I/tmp/pear/temp/bloomy -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-roothDvAr2/bloomy-0.1.0/include -I/tmp/pear/temp/pear-build-roothDvAr2/bloomy-0.1.0/main -I/tmp/pear/temp/bloomy -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/bloomy/php_bloomy.c -o php_bloomy.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/bloomy -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-roothDvAr2/bloomy-0.1.0/include -I/tmp/pear/temp/pear-build-roothDvAr2/bloomy-0.1.0/main -I/tmp/pear/temp/bloomy -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/bloomy/php_bloomy.c  -fPIC -DPIC -o .libs/php_bloomy.o
/tmp/pear/temp/bloomy/php_bloomy.c: In function 'php_bloom_new':
/tmp/pear/temp/bloomy/php_bloomy.c:213:43: error: 'zend_class_entry' has no member named 'default_properties'
make: *** [php_bloomy.lo] Błąd 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 19:38 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:38 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 08 04:01:23 2020 UTC