php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65360 wrong codification
Submitted: 2013-07-30 14:37 UTC Modified: 2016-12-30 16:24 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: petrox81 at yahoo dot it Assigned: cmb (profile)
Status: Not a bug Package: idn (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: petrox81 at yahoo dot it
New email:
PHP Version: OS:

 

 [2013-07-30 14:37 UTC] petrox81 at yahoo dot it
Description:
------------
echo idn_to_utf8('xn--sorra-lqa.it');

Test script:
---------------
wrong codification

Expected result:
----------------
sßorra.it

Actual result:
--------------
xn--sorra-lqa.it

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-07-30 15:45 UTC] ch@php.net
"ß" was specified later than the other non-ascii characters and is missing in most libraries. If you need it now, try http://www.phpclasses.org/browse/file/5855.html
 [2013-08-13 21:10 UTC] cmbecker69 at gmx dot de
IMO the reported behavior is not a bug, as it conforms to 
RFC 3490. To have an RFC 5890 conforming conversion, 
INTL_IDNA_VARIANT_UTS46 has to be given as $variant:

  idn_to_utf8('xn--sorra-lqa.it', 0, INTL_IDNA_VARIANT_UTS46);
 [2016-12-30 16:24 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-12-30 16:24 UTC] cmb@php.net
Indeed, see <https://3v4l.org/9BV5E>.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 08:03:36 2021 UTC