php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65318 Event: Support for PHP 5.5
Submitted: 2013-07-23 21:38 UTC Modified: 2013-07-24 15:34 UTC
From: cj at kuviak dot com Assigned:
Status: Not a bug Package: event (PECL)
PHP Version: 5.5.1 OS: CentOS 6.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cj at kuviak dot com
New email:
PHP Version: OS:

 

 [2013-07-23 21:38 UTC] cj at kuviak dot com
Description:
------------
I can install event 1.7.1 just fine with PHP 5.5, but I get an error on import:
PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/event.so' - 
/usr/lib64/php/modules/event.so: undefined symbol: php_sockets_le_socket in 
Unknown on line 0

Am hoping that this library will be updated to support php 5.5 soon.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-07-24 10:46 UTC] osmanov@php.net
-Status: Open +Status: Not a bug
 [2013-07-24 10:46 UTC] osmanov@php.net
The Event extension is tested under both PHP versions 5.4 and 5.5.

Make sure you have "sockets" extension installed and loaded. Most likely you've 
got a dependency problems caused by unloaded/uninstalled "sockets" 
extension(which, likely, was available at the time when the Event extension had 
been compiled).

Please provide output of the following commands:
1. php --version
2. php -m
3. arch

I'd recommend to re-install the Event extension. Let's do it manually this time:

$ sudo su -
# pecl uninstall event
# pecl download event
# tar xzf event-1.7.1.tgz
# cd event-1.7.1
# phpize --clean && phpize && make clean
# phpize
# aclocal && libtoolize --force && autoreconf
# ./configure --enable-event-debug
# make
# make test
# (see if the tests are passed)
# make install

Let's run your test script again.

Thanks.
 [2013-07-24 15:34 UTC] cj at kuviak dot com
Thanks for the help.  Here are the command outputs:

PHP Modules]
apc
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
ftp
gettext
hash
iconv
igbinary
json
libxml
mbstring
mcrypt
memcached
mhash
mysql
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
redis
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
uuid
wddx
xml
xmlreader
xmlwriter
xsl
yaml
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

PHP 5.5.0 (cli) (built: Jul 12 2013 19:03:02)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0-dev, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.2-dev, Copyright (c) 1999-2013, by Zend Technologies

x86_64

The php socket extension is installed and loaded, the dll is here: 
/usr/lib64/php/modules/sockets.so

Re-installing via the manual process you outlined was unsuccessful.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 09:01:24 2020 UTC