php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #653 configuration script does not detect Stronghold 2.4 properly
Submitted: 1998-08-13 17:37 UTC Modified: 1999-09-08 13:02 UTC
From: scotts at global2000 dot net Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0 Final Release OS: Linux 2.0.35
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: scotts at global2000 dot net
New email:
PHP Version: OS:

 

 [1998-08-13 17:37 UTC] scotts at global2000 dot net
The 'configure' script, when using --with-apache, does not properly detect a Stronghold 2.4 installation, and incorrectly configures PHP for an Apache 1.3 installation instead.

Here are diffs for the 3.0 configure script that got it to work for me:

diff configure ~/php-3.0.modified.configure
3357c3357
<         elif test -f $withval/src/main/httpd.h; then
---
>         elif [ -f $withval/src/main/httpd.h ]; then
3390c3390
<         elif test -f $withval/src/include/httpd.h; then
---
>         elif test -f $withval/src/include/httpd.h -a ! -d $withval/ssl; then
3451a3452,3485
> 
> # For StrongHold 2.4
>         elif test -f $withval/src/include/httpd.h; then
>           APACHE_INCLUDE=-"I$withval/src/include -I$withval/ssl/include -I$withval/src/os/unix"
>           APACHE_TARGET=$withval/src/modules/php3
>           BINNAME=libmodphp3.a
>           CFLAGS="$CFLAGS -DSHBUILDCODE=\\\"C2NetEU/2407\\\" -DSHVERSION=\\\"2.4\\\""
>           if test "$with_dbase" = "yes"; then
>             PHP_LIBS="-Lmodules/php3 -L../modules/php3 -lmodphp3 -ldbf"
>             INSTALL_IT="cp $BINNAME mod_php3.* php_version.h libphp3.module dbase/libdbf.a $APACHE_TARGET; cp apMakefile.tmpl $APACHE_TARGET/Makefile.tmpl; cp apMakefile.libdir $APACHE_TARGET/Makefile.libdir; cp libphp3.module $APACHE_TARGET"
>           else
>             PHP_LIBS="-Lmodules/php3 -L../modules/php3 -lmodphp3"
>             INSTALL_IT="cp $BINNAME mod_php3.* php_version.h libphp3.module $APACHE_TARGET; cp apMakefile.tmpl $APACHE_TARGET/Makefile.tmpl; cp apMakefile.libdir $APACHE_TARGET/Makefile.libdir; cp libphp3.module $APACHE_TARGET"
>           fi
>               STRONGHOLD=-DSTRONGHOLD=1
>           cat >> confdefs.h <<\EOF
> #define APACHE 1
> EOF
> 
>               echo "$ac_t""yes - StrongHold" 1>&6
>               if test -f $withval/src/include/ap_config.h; then
>               cat >> confdefs.h <<\EOF
> #define HAVE_AP_CONFIG_H 1
> EOF
> 
>               fi
>               if test -f $withval/src/include/compat.h; then
>               cat >> confdefs.h <<\EOF
> #define HAVE_AP_COMPAT_H 1
> EOF
> 
>               fi
> 
> 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-06-01 16:44 UTC] jim at cvs dot php dot net
Is this still true?
 [1999-09-08 13:02 UTC] rasmus at cvs dot php dot net
Old and outdated.  Re-submit if the problem persists in the latest version.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 08 01:05:45 2022 UTC