php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65096 The fopen manager does not work, even if it is set to On in php.ini
Submitted: 2013-06-22 09:38 UTC Modified: 2013-06-22 10:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: taoschreiner at hotmail dot fr Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.5.0 OS: Win7 x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: taoschreiner at hotmail dot fr
New email:
PHP Version: OS:

 

 [2013-06-22 09:38 UTC] taoschreiner at hotmail dot fr
Description:
------------
Despite the fact it is specified in the configuration file that PHP can view 
distant files using fopen(), imagecreatefromXXX() and other functions, it doesn't 
seem to work.

[php.ini]
allow_url_fopen = On
allow_url_include = On

Test script:
---------------
<?php
    $php = fopen('https://bugs.php.net', 'r');
    fclose($php);

Actual result:
--------------
PHP Warning:  fopen(): Unable to find the wrapper &quot;https&quot; - did you 
forget to enable it when you configured PHP? in C:\\www\\index.php on line 2
PHP Warning:  fopen(https://bugs.php.net): failed to open stream: Invalid argument 
in C:\\www\\index.php on line 2
PHP Warning:  fclose() expects parameter 1 to be resource, boolean given in 
C:\\www\\index.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-22 10:00 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2013-06-22 10:00 UTC] ab@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Please enable the openssl extension in order to use the https wrapper.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 05:05:45 2022 UTC