php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64918 Infinite loop when using SimpleXMLElement::attributes
Submitted: 2013-05-24 13:18 UTC Modified: 2013-05-24 15:38 UTC
From: nabice at gmail dot com Assigned:
Status: Duplicate Package: SimpleXML related
PHP Version: 5.4.15 OS: Linux 3.8.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nabice at gmail dot com
New email:
PHP Version: OS:

 

 [2013-05-24 13:18 UTC] nabice at gmail dot com
Description:
------------
When I use SimpleXML to find some element's attributes, A mistake leads to 
infinite loop.

I was meaning "$child->atttibutes()", but "$childs->attributes()" by mistake, 
then some strange things happen: Infinite loop.

Is it a bug?

Test script:
---------------
<?php
$xml = simplexml_load_string('<root><parent><child id="1"/><child id="2"/></parent></root>');
$childs = $xml->parent->child;
foreach($childs as $child){
	var_dump($childs->attributes());
}
?>

Expected result:
----------------
Print:

object(SimpleXMLElement)#6 (1) {
  ["@attributes"]=>
  array(1) {
    ["id"]=>
    string(1) "1"
  }
}
object(SimpleXMLElement)#6 (1) {
  ["@attributes"]=>
  array(1) {
    ["id"]=>
    string(1) "1"
  }
}

Actual result:
--------------
Infinite loop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-24 15:38 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2013-05-24 15:38 UTC] aharvey@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 [2013-05-24 15:38 UTC] aharvey@php.net
-Status: Not a bug +Status: Duplicate
 [2013-05-24 15:38 UTC] aharvey@php.net
Note to self: "submitted twice" isn't very useful. Sorry about the bugspam.

Duplicate of bug #64917, anyway.
 [2013-05-25 02:40 UTC] nabice at gmail dot com
Sorry, I thought I failed to submit 64917, so I submit this one.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 08:01:27 2024 UTC