php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #64869 [RU] Broken DateTime documentation
Submitted: 2013-05-17 11:20 UTC Modified: 2013-10-15 11:54 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: rand0m05 at inbox dot ru Assigned:
Status: No Feedback Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rand0m05 at inbox dot ru
New email:
PHP Version: OS:

 

 [2013-05-17 11:20 UTC] rand0m05 at inbox dot ru
Description:
------------
In first example on page http://www.php.net/manual/ru/datetime.diff.php must be string
echo $interval->format('%R%d дней');
instead of
echo $interval->format('%R% дней');
(russian language)


---
From manual page: http://www.php.net/datetime.diff#refsect1-datetime.diff-examples
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-24 23:24 UTC] philip@php.net
-Summary: Lost letter d +Summary: [RU] Broken DateTime documentation -Status: Open +Status: Verified -Package: Documentation problem +Package: Translation problem
 [2013-06-24 23:24 UTC] philip@php.net
And now this function (and I assume others) is missing from the Russian 
translation. Compare:

http://php.net/manual/ru/book.datetime.php
http://php.net/manual/en/book.datetime.php
 [2013-06-25 07:15 UTC] rand0m05 at inbox dot ru
-Status: Verified +Status: Closed
 [2013-06-25 07:15 UTC] rand0m05 at inbox dot ru
What? Function DateInterval::format() is in the function list now.
But incorrect example was deleted from it description page, OK.
 [2013-06-25 15:50 UTC] philip@php.net
-Status: Closed +Status: Feedback
 [2013-06-25 15:50 UTC] philip@php.net
This is about diff, so for example:

http://php.net/manual/en/class.datetimeinterface.php (exists)
http://php.net/manual/en/class.datetimeinterface.php (does not exist)

Or more specifically:

http://php.net/manual/en/datetime.diff.php (exists)
http://php.net/manual/ru/datetime.diff.php (does not exist)
 [2013-10-15 11:54 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 15 12:01:25 2020 UTC