php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64817 BuildExcerpts not working if passed options
Submitted: 2013-05-11 13:10 UTC Modified: 2013-05-12 16:59 UTC
From: irxpoder at gmail dot com Assigned:
Status: Not a bug Package: sphinx (PECL)
PHP Version: 5.4.15 OS: Centos 6.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: irxpoder at gmail dot com
New email:
PHP Version: OS:

 

 [2013-05-11 13:10 UTC] irxpoder at gmail dot com
Description:
------------
This dont works:
$options = array("limit" => "700", "around" => "40");
sphinx->BuildExcerpts(array($mysqlb['post_text']), "nsinfo", $searchterm, $options); 

This works:

sphinx->BuildExcerpts(array($mysqlb['post_text']), "nsinfo", $searchterm); 

Test script:
---------------
<?php
$options = array("limit" => "700", "around" => "40");
sphinx->BuildExcerpts(array($mysqlb['post_text']), "nsinfo", $searchterm, $options); 
?>

Expected result:
----------------
Building excerpts

Actual result:
--------------
bools false if passed options

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-11 16:36 UTC] irxpoder at gmail dot com
Delete this bug, it was a repo bug from remi. Sorry
 [2013-05-11 16:37 UTC] irxpoder at gmail dot com
closed no bug
 [2013-05-11 16:37 UTC] irxpoder at gmail dot com
-Status: Open +Status: Closed
 [2013-05-12 16:59 UTC] tony2001@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 17:01:26 2020 UTC