php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64771 Error: require_­once­(­)­: Unable to allocate memory for pool.
Submitted: 2013-05-03 11:25 UTC Modified: 2013-05-07 13:42 UTC
From: tech at neodynamics dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.3.24 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tech at neodynamics dot com
New email:
PHP Version: OS:

 

 [2013-05-03 11:25 UTC] tech at neodynamics dot com
Description:
------------
I have a x-cart 4.4.2 Pro based store having the following configurations-
Environment info-	
Component 	Status 	 
X-Cart version 	4.4.2 	 
X-Cart directory 	/var/www/html/mydomain.com/httpdocs 	 
PHP 	5.3.10-1ubuntu3.5 	
GD 	2.0 	 
MySQL server 	5.1.45 	 
MySQL client 	5.5.29 	 
DB size 	415.349Mb 	 
Web server 	Apache/2.2.22 (Ubuntu) 	 
Operation system 	Linux 	 
Perl 	5.014002 	Details >>
XML parser (expat) 	found 	 
X-Cart directory size 	Estimate the directory size 	 
HTTPS modules
Net::SSLeay 	1.42 	 
libCURL 	7.22.0 	Active >>
CURL executable 	curl 7.22.0 (x86_64-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3 	 
OpenSSL executable 	OpenSSL 1.0.1 14 Mar 2012 

I am facing the following problems and site become down.


Test script:
---------------
1)/home.php raised
Error: require_­once­(­)­: Unable to allocate memory for pool.­
… called at /var/www/html/mydomain.com/httpdocs/include/func/
func.core.php (70)
in x_load called at /var/www/html/mydomain.com/httpdocs/init.php (61)
in include_once called at /var/www/html/mydomain.com/httpdocs/preauth.php (69)
in require called at /var/www/html/mydomain.com/httpdocs/auth.php (63)
in require called at /var/www/html/mydomain.com/httpdocs/home.php (52)

2)/dispatcher.php raised
Error: require_­once­(­)­: Unable to allocate memory for pool.­

… called at /var/www/html/mydomain.com/httpdocs/include/func/
func.core.php (70)
in x_load called at /var/www/html/mydomain.com/httpdocs/init.php (61)
in include_once called at /var/www/html/mydomain.com/httpdocs/preauth.php (69)
in require called at /var/www/html/mydomain.com/httpdocs/dispatcher.php (50)

3)/adaptive.php raised
Error: require_­once­(­)­: Unable to allocate memory for pool.­

… called at /var/www/html/mydomain.com/httpdocs/include/func/
func.core.php (70)
in x_load called at /var/www/html/mydomain.com/httpdocs/init.php (61)
in require called at /var/www/html/mydomain.com/httpdocs/adaptive.php (51)



Expected result:
----------------
My site frequently down and facing error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-07 13:42 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is not a matter of core PHP but APC configuration. Proalyyouneed more/larger shared memory segments for APC or shorter time to live or some filtering or ... see http://php.net/apc.configuration
 [2013-05-07 13:42 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2013-05-07 13:43 UTC] johannes@php.net
"Probably you need" I meant to write ...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 19 21:03:36 2022 UTC