php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #64673 Call to undefined method AMQPConnection::setTimeout()
Submitted: 2013-04-18 23:24 UTC Modified: 2014-11-27 18:32 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: nathan dot goulding at gmail dot com Assigned: lstrojny (profile)
Status: Closed Package: amqp (PECL)
PHP Version: 5.3.24 OS: Centos 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nathan dot goulding at gmail dot com
New email:
PHP Version: OS:

 

 [2013-04-18 23:24 UTC] nathan dot goulding at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/amqpconnection.settimeout
---

The method is identified as setTimeout() and doesn't appear to exist.

Test script:
---------------
<?php

$connection = new AMQPConnection();

$connection->setHost('host');
$connection->setLogin('login');
$connection->setPassword('password');
$connection->setTimeout(5);


Expected result:
----------------
The timeout on the connection to be set to 5 seconds.

Actual result:
--------------
PHP Fatal error:  Call to undefined method AMQPConnection::setTimeout() in 
test.php on line 8

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-02-01 16:54 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: lstrojny
 [2014-02-01 16:54 UTC] krakjoe@php.net
The method definitely exists today, and is marked deprecated in the latest source too.

Assigning to one of the authors ...
 [2014-02-01 16:54 UTC] krakjoe@php.net
-Status: Not a bug +Status: Open
 [2014-11-04 13:28 UTC] prabhukeer1992 at gmail dot com
eeererr
 [2014-11-27 18:32 UTC] lstrojny@php.net
-Status: Assigned +Status: Closed
 [2014-11-27 18:32 UTC] lstrojny@php.net
Use either setReadTimeout() or setWriteTimeout() instead of setTimeout()
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jul 29 07:01:24 2021 UTC